Bug 205399 - net/openbsc: Use default FreeBSD OpenSSL
Summary: net/openbsc: Use default FreeBSD OpenSSL
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jason Unovitch
URL:
Keywords: easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2015-12-18 14:29 UTC by Nikola Kolev
Modified: 2015-12-28 02:37 UTC (History)
1 user (show)

See Also:


Attachments
openbsc openssl (1.49 KB, patch)
2015-12-18 14:29 UTC, Nikola Kolev
vlad-fbsd: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 VK freebsd_triage 2015-12-18 14:45:33 UTC
Thanks for the submission.

Please note that you can approve all the patches for ports you're maintainer of, by setting maintainer-approval + on them. ;)

By the way, does this fix a regression of some kind? Or is it just to standardize on the default being the base?
Comment 2 Nikola Kolev 2015-12-18 14:50:56 UTC
Just to standardize on the default being the base.
Comment 3 commit-hook freebsd_committer 2015-12-28 02:36:20 UTC
A commit references this bug:

Author: junovitch
Date: Mon Dec 28 02:35:56 UTC 2015
New revision: 404614
URL: https://svnweb.freebsd.org/changeset/ports/404614

Log:
  net/openbsc: remove hard requirement on LibreSSL introduced in r402149

  PR:		205399
  Submitted by:	Nikola Kolev <koue@chaosophia.net> (maintainer)

Changes:
  head/net/openbsc/Makefile
  head/net/openbsc/files/patch-configure.ac
Comment 4 Jason Unovitch freebsd_committer 2015-12-28 02:37:28 UTC
Nikola,
Since this introduces a change in dependencies this also required a PORTREVISION bump.  Otherwise the update is committed.  Thanks for taking care of this port!