Bug 206440 - UEFI boot fails on UEFI capable machine with successful install
Summary: UEFI boot fails on UEFI capable machine with successful install
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 10.2-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-20 19:34 UTC by aviator45003
Modified: 2016-02-18 02:28 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description aviator45003 2016-01-20 19:34:54 UTC
Sometimes I get the attached screen outputs after a successful UEFI install.

Once I didn't (I booted successfully into the new install) and was
convinced that was because I wiped the drive first, but it seems I was
wrong.

Dmesg from a successful BIOS mode boot also attached.

Thanks for any help.

--

error:

http://imgur.com/a/QY3lb

dmesg:

https://gist.github.com/d88182e41b1b3f205cec

pciconf -l output:

https://gist.github.com/533639fe1b1ee7169511
Comment 1 Steven Hartland freebsd_committer 2016-01-20 20:45:27 UTC
How often do you get the error?

Can you provoke it?

Given the error and the random nature you may have a hardware fault.

Have you tried a memory test?

There has been a lot of changes in EFI recently in head, while I'm not personally aware of any changes that might fix this, if you can provoke it regularly then it might be worth testing head to see if any of said changes do fix it.
Comment 2 aviator45003 2016-01-21 02:23:58 UTC
(In reply to Steven Hartland from comment #1)

It is a regular thing - it occurs every boot from installed media in UEFI mode

The machine is stable running FreeBSD in BIOS mode right now.

The only way to get it to work was installing BIOS mode, booting into the install, rebooting into the UEFI installer, and installing in UEFI mode. Only then would it successfully boot. Not a ranom failure, that printout you saw could happen any time I booted with no differences.

I have not tried a memory test.

I can try burning HEAD to a disk and testing it if that is the best solution.

http://imgur.com/a/uS6g6 is what it looks like when I try entering things at the prompt, on a different attempt to boot an installed UEFI FreeBSD.
Comment 3 Steven Hartland freebsd_committer 2016-01-21 02:41:38 UTC
I see your devices are mfi another thing you might want to try is switch to mrsas.

If you have this in the kernel (its not by default) or as a module you can:
* load mrsas
* set hw.mfi.mrsas_enable 1

This will give you daX devices instead of mfipdX so you'll need to update your root too.

Quite a few stabs in the dark I'm afraid, but hope something turns up some useful info.
Comment 4 aviator45003 2016-01-21 03:13:58 UTC
(In reply to Steven Hartland from comment #3)

The boot medium is a hardware mirror of 2 SAS drives.

I wouldn't have a place to set those options on the booting medium due to the crashing before I get to a useable prompt.

I appreciate your suggestions.
Comment 5 aviator45003 2016-01-21 03:21:19 UTC
In addition, are the mfi vs. mrsas drivers different in UEFI vs. BIOS? It works great in BIOS.
Comment 6 Steven Hartland freebsd_committer 2016-01-21 08:51:36 UTC
All those can, and need to be, done from the boot loader prompt, which is why I mentioned it ;-)
Comment 7 Steven Hartland freebsd_committer 2016-02-18 02:28:22 UTC
Any joy?