Bug 206697 - [new port] cad/fritzing: PCB cad in QT5
Summary: [new port] cad/fritzing: PCB cad in QT5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Kurt Jaeger
URL:
Keywords: feature, patch
Depends on:
Blocks:
 
Reported: 2016-01-28 00:07 UTC by lenzi.sergio
Modified: 2016-02-01 06:25 UTC (History)
1 user (show)

See Also:


Attachments
fritzing, pcb & electronic software for FreeBSD (562.87 KB, text/plain)
2016-01-28 00:07 UTC, lenzi.sergio
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description lenzi.sergio 2016-01-28 00:07:50 UTC
Created attachment 166214 [details]
fritzing, pcb & electronic software for FreeBSD

a port for the fritzing http://fritzing.org using QT5

This port builds the PARTS library in 
the /usr/local/share fritzing for the version 0.9.2b (2015)
Comment 1 Kurt Jaeger freebsd_committer 2016-01-29 17:39:09 UTC
Testbuilds@work
Comment 2 Kurt Jaeger freebsd_committer 2016-01-29 20:43:33 UTC
Building the port in poudriere fails at configure with the error:

===>   fritzing-0.9.2_3 depends on shared library: libpango-1.0.so - found (/usr/local/lib/libpango-1.0.so)
===>  Configuring for fritzing-0.9.2_3
Project ERROR: Unknown module(s) in QT: xml printsupport concurrent
*** Error code 3

Full log see

http://people.freebsd.org/~pi/logs/cad__fritzing-10a-1454089363.txt

Any ideas for the cause of this ?
Comment 3 Kurt Jaeger freebsd_committer 2016-01-31 18:40:07 UTC
The USE_QT5 needed additional entries for xml printsupport and concurrent.

Now it wants rcc, too. The qt4-rcc port does not seem to work.
Comment 4 Kurt Jaeger freebsd_committer 2016-01-31 22:07:58 UTC
Testbuilds on 11a, 10.2a+i, 9.3 are OK with some modifications to the port.
Comment 5 commit-hook freebsd_committer 2016-02-01 06:24:38 UTC
A commit references this bug:

Author: pi
Date: Mon Feb  1 06:23:43 UTC 2016
New revision: 407684
URL: https://svnweb.freebsd.org/changeset/ports/407684

Log:
  New port: cad/fritzing

  Fritzing is an Electronic Design Automation software with a low
  entry barrier, suited for the needs of designers and artists. It
  uses the metaphor of the breadboard, so that it is easy to transfer
  your hardware sketch to the software. From there it is possible to
  create PCB layouts for turning it into a robust PCB yourself or by
  help of a manufacturer.

  WWW: http://fritzing.org/

  PR:		206697
  Submitted by:	lenzi.sergio@gmail.com

Changes:
  head/cad/Makefile
  head/cad/fritzing/
  head/cad/fritzing/Makefile
  head/cad/fritzing/distinfo
  head/cad/fritzing/files/
  head/cad/fritzing/files/patch-fritzing.desktop
  head/cad/fritzing/files/patch-phoenix.pro
  head/cad/fritzing/files/pkg-install.in
  head/cad/fritzing/pkg-descr
  head/cad/fritzing/pkg-plist
Comment 6 Kurt Jaeger freebsd_committer 2016-02-01 06:25:09 UTC
Committed, thanks!