Bug 206799 - security/govpn: Update to 5.4
Summary: security/govpn: Update to 5.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords: patch, patch-ready
Depends on:
Blocks:
 
Reported: 2016-01-31 16:05 UTC by Sergey Matveev
Modified: 2016-02-01 17:17 UTC (History)
1 user (show)

See Also:


Attachments
Update patch from 5.3 -> 5.4 (771 bytes, patch)
2016-01-31 16:05 UTC, Sergey Matveev
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Matveev 2016-01-31 16:05:56 UTC
Created attachment 166356 [details]
Update patch from 5.3 -> 5.4

Update GoVPN to 5.4.
Comment 1 Kurt Jaeger freebsd_committer 2016-02-01 17:11:51 UTC
testbuilds all fine.
Comment 2 commit-hook freebsd_committer 2016-02-01 17:15:46 UTC
A commit references this bug:

Author: pi
Date: Mon Feb  1 17:15:42 UTC 2016
New revision: 407727
URL: https://svnweb.freebsd.org/changeset/ports/407727

Log:
  security/govpn: 5.3 -> 5.4

  - Added optional time synchronization requirement.
    It will add timestamps in handshake PRP authentication, disallowing to
    repeat captured packet and get reply from the server, making it visible
    to DPI.

  PR:		206799
  Submitted by:	Sergey Matveev <stargrave@stargrave.org> (maintainer)

Changes:
  head/security/govpn/Makefile
  head/security/govpn/distinfo
Comment 3 Kurt Jaeger freebsd_committer 2016-02-01 17:17:11 UTC
Committed, thanks.