Bug 206846 - x11/rofi: Update to 0.15.12 and unbreak i3 support
Summary: x11/rofi: Update to 0.15.12 and unbreak i3 support
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL: https://github.com/DaveDavenport/rofi...
Keywords: patch, patch-ready
: 206745 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-02 12:59 UTC by Tobias Kortkamp
Modified: 2016-02-20 11:25 UTC (History)
2 users (show)

See Also:
nomoo: maintainer-feedback+
nomoo: maintainer-feedback+
pi: merge-quarterly+


Attachments
rofi.diff (2.20 KB, patch)
2016-02-02 12:59 UTC, Tobias Kortkamp
no flags Details | Diff
Poudriere testport log FreeBSD 10.2/amd64 with I3 enabled (34.81 KB, text/x-log)
2016-02-02 13:00 UTC, Tobias Kortkamp
no flags Details
rofi-2016q1.diff (1.53 KB, patch)
2016-02-02 13:31 UTC, Tobias Kortkamp
no flags Details | Diff
rofi_bugfix.diff (1.78 KB, patch)
2016-02-02 14:00 UTC, Tobias Kortkamp
tobik: maintainer-approval? (nomoo)
Details | Diff
rofi_version.diff (797 bytes, patch)
2016-02-02 14:01 UTC, Tobias Kortkamp
tobik: maintainer-approval? (nomoo)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Kortkamp freebsd_committer 2016-02-02 12:59:03 UTC
Created attachment 166435 [details]
rofi.diff

The I3 option of the port was broken and compiled rofi without i3 support even when the option was enabled.  There also was an issue where i3 support did not work correctly even when compiled in.  See attached patch.  I've reported the issue, my patch was merged, and hopefully will be included in the next release.
Comment 1 Tobias Kortkamp freebsd_committer 2016-02-02 13:00:06 UTC
Created attachment 166436 [details]
Poudriere testport log FreeBSD 10.2/amd64 with I3 enabled
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2016-02-02 13:08:58 UTC
Thank you Tobias

If you could include breadcrumbs (comments), with upstream issue,list,pr references if applicable, that would be great
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2016-02-02 13:09:28 UTC
It may be worth separating out the version update from the unbreak change, such that merging to the quarterly branch is possible.
Comment 4 Tobias Kortkamp freebsd_committer 2016-02-02 13:31:57 UTC
Created attachment 166437 [details]
rofi-2016q1.diff

Upstream pull request is here: https://github.com/DaveDavenport/rofi/pull/330

I've attached a patch rofi-2016q.diff to the port in the quarterly branch without the version update.

I hope this is ok here, or should I have opened another bug?
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2016-02-02 13:41:45 UTC
Very good attempt (we have two changesets), but what we need is:

* Two patches, both for head (bugfix, version update)

These can then be to be committed serially, with the bugfix first (with portrevision bump, then the version update. The first one can/will them be merged

Also, what I meant by comment 2, was to add a comment in the patch header itself, like so:

# Description: Use correct namelen when connecting to i3 socket
# Pull Request: https://github.com/DaveDavenport/rofi/pull/330
Comment 6 Tobias Kortkamp freebsd_committer 2016-02-02 14:00:19 UTC
Created attachment 166439 [details]
rofi_bugfix.diff
Comment 7 Tobias Kortkamp freebsd_committer 2016-02-02 14:01:27 UTC
Created attachment 166440 [details]
rofi_version.diff
Comment 8 Tobias Kortkamp freebsd_committer 2016-02-02 14:03:37 UTC
Ok, two new patches.

rofi_bugfix.diff is for unbreaking i3 support, and rofi_version.diff for updating to 0.15.12 (after rofi_bugfix.diff was applied).
Comment 9 Kubilay Kocak freebsd_committer freebsd_triage 2016-02-02 14:05:07 UTC
Perfecto!
Comment 10 Kurt Jaeger freebsd_committer 2016-02-03 21:15:31 UTC
Please note 

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=206745

which has a patch to upgrade from the maintainer.
Comment 11 Kubilay Kocak freebsd_committer freebsd_triage 2016-02-04 06:53:18 UTC
*** Bug 206745 has been marked as a duplicate of this bug. ***
Comment 12 nomoo 2016-02-10 21:38:42 UTC
yep, working :) Thank you, Tobias!
Comment 13 commit-hook freebsd_committer 2016-02-20 08:13:27 UTC
A commit references this bug:

Author: pi
Date: Sat Feb 20 08:12:25 UTC 2016
New revision: 409225
URL: https://svnweb.freebsd.org/changeset/ports/409225

Log:
  x11/rofi: fix I3 option

  MFH:		2016Q1
  PR:		206846
  Submitted by:	Tobias Kortkamp <t@tobik.me>
  Approved by:	nomoo@nomoo.ru (maintainer)

Changes:
  head/x11/rofi/Makefile
  head/x11/rofi/files/
  head/x11/rofi/files/patch-source_i3-support.c
Comment 14 commit-hook freebsd_committer 2016-02-20 08:16:29 UTC
A commit references this bug:

Author: pi
Date: Sat Feb 20 08:16:01 UTC 2016
New revision: 409226
URL: https://svnweb.freebsd.org/changeset/ports/409226

Log:
  x11/rofi: fix I3 option

  MFH:		r409224
  PR:		206846
  Submitted by:	Tobias Kortkamp <t@tobik.me>
  Approved by:	ports-secteam (blanket)

Changes:
  branches/2016Q1/x11/rofi/Makefile
  branches/2016Q1/x11/rofi/files/
  branches/2016Q1/x11/rofi/files/patch-source_i3-support.c
Comment 15 commit-hook freebsd_committer 2016-02-20 11:23:50 UTC
A commit references this bug:

Author: pi
Date: Sat Feb 20 11:23:40 UTC 2016
New revision: 409231
URL: https://svnweb.freebsd.org/changeset/ports/409231

Log:
  x11/rofi: 0.15.11 -> 0.15.12

  New features:
  - Initial `-dump` command for dmenu mode. (#216)
  - Threading support.
    o Parallel checking for ASCII.
    o Parallel string matching.
    o Autodetect number of HW-threads.
    o Disabled by default.
  - Highlight multiple selected rows (#287,#293)
  - Dmenu can read from file instead of stdin.
  - Regex matching (#113)
  - Take Screenshot of rofi using keybinding.
  - Hotkey for sorting: (#298) Option to set scrollbar width.

  Improvements:
  - Fix return code of multi-select.
  - Update manpage (#289, #291)
  - Improve speed of reading stdin in dmenu mode.
  - Correctly handle modifier keys now. Should now support most
    weird keyboard layouts and switching between them.
    (#268, #265, #286)
  - Correctly set locale, fixing issues with entering special
    characters. (#282)
  - DRun mode support `NoDisplay` setting (#283)
  - Pango markup is matched when filtering. (#273)

  Bug fixes:
  - Improve error message (#290)
  - Correctly switch to next entry on multi-select when list is filtered (#292)
  - Switch __FUNCTION__ for __func__. (#288)
  - Fix segfault on empty list and moving through it. (#256,#275)
  - Fix one off of colors (#269)
  - Drun fix uninitialized memory (#285)

  PR:		206846
  Submitted by:	Tobias Kortkamp <t@tobik.me>
  Approved by:	nomoo@nomoo.ru

Changes:
  head/x11/rofi/Makefile
  head/x11/rofi/distinfo
Comment 16 Kurt Jaeger freebsd_committer 2016-02-20 11:25:52 UTC
Testbuilds fine, portlint OK, committed, thanks!