Bug 207251 - stuck at "mountroot: waiting ..." on Toshiba Chromebook 2
Summary: stuck at "mountroot: waiting ..." on Toshiba Chromebook 2
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Some People
Assignee: FreeBSD bugs mailing list
Depends on:
Reported: 2016-02-16 17:40 UTC by johnnywhishbone
Modified: 2016-03-22 18:51 UTC (History)
3 users (show)

See Also:

Image of the screen as it get stuck (178.73 KB, image/jpeg)
2016-02-16 17:40 UTC, johnnywhishbone
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description johnnywhishbone 2016-02-16 17:40:00 UTC
Created attachment 167084 [details]
Image of the screen as it get stuck


i try to boot the usb-installer on an Toshiba Chromebook 2 (CB30-B-104) but it get stuck the moment it tries to find the rootdevice it is booting from. Keyboard input is not recognized. There seems to be no recognized usb devices. It doesn't matter if i boot via usb stick or sd card and using amd64 or i386.

Neither OpenBSD, NetBSD nor DragonFly are booting, wether it is the most recent snapshot. I also makes no difference using i386 or amd64. Linux is working fine, so i could create a dmesg and lspci from there.

dmesg (Arch Linux): http://pastebin.com/FNEhYdsZ
lspci (Arch Linux): http://pastebin.com/pnFErXqG 

The Chromebook has a flashed Coreboot / SeaBIOS to enable booting alternative OS besides ChromeOS.

I opened a bug on DragonFlyBSD yesterday, because the installer doesn't boot too: http://bugs.dragonflybsd.org/issues/2890

Using the latest NetBSD snapshot the kernel crashes and i find myself thrown into the debugger. This seems to be ACPI related.

idk if these bugs are related, because i'm using a Bay Trail device ("Swanky") and those are Haswell devices:

Please let me know if i can provide more informations!

Thank you!
-- Ronny Schneider
Comment 1 johnnywhishbone 2016-02-16 18:01:51 UTC
I'm sorry but i have to correct myself.

The bugreport i first posted is for i386!

If i use an amd64-image from CURRENT the kernel panics and starts the debugger.

Image: http://bilderhochladen.org/i/27rjseh57/

The same happens using the latest snapshot of NetBSD amd64.
So the two bugs i linked, whom i don't know if the apply to my Chromebook, seem to be relevant. This leaves the problem of no found usb device on which the installer root filesystem lays.

-- Ronny Schneider
Comment 2 johnnywhishbone 2016-02-17 10:39:42 UTC
I've spend some hours figuring out what the problem could be and used the most recent snapshot 20160206-r295345 i found with i386 and amd64.


- Standard boot options (just pressed enter at the boot screen)
* Kernel starts, boot stops at "mountroot: waiting for device /dev/ufs/FreeBSD_install..."
* No reaction to keyboard inputs

- ACPI turned off:
* Kernel starts, boot stops at "IPsec: Initialized Security Association Processing."
* No reaction to keyboard inputs
* Chromebook shuts down if the powerbutton is pressed once

- Standard boot options
* Kernel starts, boot stops at "mountroot: waiting for device /dev/ufs/FreeBSD_install..."
* No reaction to keyboard inputs

- ACPI turned off:
* Kernel crashes. "panic: running without device atpic requires a local APIC"
Image: http://bilderhochladen.org/i/IZQ4o9y2sb/
* Chromebook shuts down if the powerbutton is pressed once
Comment 3 johnnywhishbone 2016-02-22 11:36:10 UTC
I tried the 10.1-RELEASE amd64 mini-image and it worked. Installer boots, usb stick and some other peripherals are recognized and useable. Even usb 3 super speed is working correct and allow to boot. Although the keyboard is not working. I'm using an usb keyboard, which works flawlessly.

Using 10.2-RELEASE onwards it isn't working any more. No usb stick i recognized. The whole usb system seems to be not working as the illuminating keys of the usb keyboard aren't shining.

Maybe this is related: https://lists.freebsd.org/pipermail/freebsd-current/2013-September/044481.html
Comment 4 Edward Tomasz Napierala freebsd_committer 2016-03-22 18:10:14 UTC
Does the problem still occur with 10.3-RC3?
Comment 5 johnnywhishbone 2016-03-22 18:51:13 UTC
(In reply to Edward Tomasz Napierala from comment #4)
Yes, it does.