Bug 207460 - [exp-run] devel/git-lite: Wrong dependency on perl5 (inherits master port option)
Summary: [exp-run] devel/git-lite: Wrong dependency on perl5 (inherits master port opt...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Bryan Drewery
URL:
Keywords: easy, needs-patch, needs-qa, regression
Depends on:
Blocks: 202701
  Show dependency treegraph
 
Reported: 2016-02-24 12:20 UTC by Edoardo Spadolini
Modified: 2016-05-03 18:36 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (garga)
bdrewery: exp-run?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Edoardo Spadolini 2016-02-24 12:20:52 UTC
The devel/git-lite port sets PERL in OPTIONS_EXCLUDE but perl gets pulled in as a dependency anyway, because the SEND_EMAIL option enables PERL anyway; maybe the git-lite port should selectively enable some options from the git port instead of selectively disabling them.
Comment 1 Bryan Drewery freebsd_committer 2016-03-03 05:44:54 UTC
Really the SEND_EMAIL_IMPLIES=PERL line should integrate with the git-lite slave's OPTIONS_EXCLUDE=PERL to remove SEND_EMAIL from the build since it is implied.

This handles it:

https://people.freebsd.org/~bdrewery/patches/options-slave-exclude-implied.txt
Comment 2 Bryan Drewery freebsd_committer 2016-03-03 17:40:58 UTC
https://reviews.freebsd.org/D5538
Comment 3 Mathieu Arnold freebsd_committer 2016-03-22 10:45:26 UTC
Does the attached patch/review fix the problem for you ?
Comment 4 Bryan Drewery freebsd_committer 2016-03-22 16:23:26 UTC
Assign to portmgr for exp-run
Comment 5 Antoine Brodin freebsd_committer 2016-03-24 15:35:17 UTC
This change affects only 1 port (with default options):

[00:03:32] ====>> Deleting git-lite-2.7.4_1.txz: changed options
[00:03:32] ====>> Pkg: CURL ETCSHELLS ICONV NLS SEND_EMAIL
[00:03:32] ====>> New: CURL ETCSHELLS ICONV NLS
Comment 6 commit-hook freebsd_committer 2016-05-03 18:36:47 UTC
A commit references this bug:

Author: bdrewery
Date: Tue May  3 18:36:29 UTC 2016
New revision: 414547
URL: https://svnweb.freebsd.org/changeset/ports/414547

Log:
  Fix excluding implied options.

  This fixes the devel/git-lite port to not get PERL despite being excluded.

  PR:		207460
  PR:		202701
  With hat:	portmgr
  Differential Revision:	https://reviews.freebsd.org/D5538

Changes:
  head/Mk/bsd.options.mk