Bug 207876 - mail/mailman: htdig patch clashes with patch-LP1551075
Summary: mail/mailman: htdig patch clashes with patch-LP1551075
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Matthias Andree
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-10 10:04 UTC by David Siebörger
Modified: 2016-03-10 19:52 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (mandree)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Siebörger 2016-03-10 10:04:33 UTC
The msapiro-htdig-1632.patch.xz for htdig support includes the changes which patch-LP1551075 makes.  As a result, patch-LP1551075 cannot be applied, as shown below.  Would it be possible to recreate the htdig patch without the LP1551075 changes or not apply the patch-LP1551075 when the HTDIG option is enabled, please?


# make

You may change the following build options:

Option          Default Value   Description
-------------   --------------- ------------------------------------------------
MM_USERNAME     mailman         The username of the Mailman user.
MM_USERID       91              The user ID of the Mailman user.
MM_GROUPNAME    mailman         The group to which the Mailman user will belong.
MM_GROUPID      $MM_USERID      The group ID for the Mailman user.
MM_DIR          mailman         Mailman will be installed in
                                /usr/local/mailman.
CGI_GID         www             The group name or id under which your web
                                server executes CGI scripts.
IMGDIR          www/icons       Icon images will be installed in
                                /usr/local/www/icons.

===>  License GPLv2 accepted by the user
===>  Found saved configuration for mailman-2.1.21_3
===>   mailman-with-htdig-2.1.21_3 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by mailman-with-htdig-2.1.21_3 for building
===>  Extracting for mailman-with-htdig-2.1.21_3
=> SHA256 Checksum OK for mailman/mailman-2.1.21.tgz.
=> SHA256 Checksum OK for mailman/msapiro-htdig-1632.patch.xz.
===>  Patching for mailman-with-htdig-2.1.21_3
===>  Applying distribution patches for mailman-with-htdig-2.1.21_3
===>  Applying FreeBSD patches for mailman-with-htdig-2.1.21_3
Ignoring previously applied (or reversed) patch.
2 out of 2 hunks ignored--saving rejects to Mailman/Handlers/MimeDel.py.rej
Ignoring previously applied (or reversed) patch.
1 out of 1 hunks ignored--saving rejects to NEWS.rej
=> Patch patch-LP1551075 failed to apply cleanly.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/mail/mailman
*** Error code 1

Stop.
make: stopped in /usr/ports/mail/mailman
Comment 1 commit-hook freebsd_committer 2016-03-10 19:50:57 UTC
A commit references this bug:

Author: mandree
Date: Thu Mar 10 19:50:13 UTC 2016
New revision: 410774
URL: https://svnweb.freebsd.org/changeset/ports/410774

Log:
  Avoid patch-LP1551075 when HTDIG is enabled. [1]

  This patch is part of the HTDIG integration patch already. [1]

  Also correct namazurc file path in pkg-message, bumping PORTREVISION.

  PR:		207876 [1]
  Submitted by:	David Sieb?rger [1]

Changes:
  head/mail/mailman/Makefile
  head/mail/mailman/files/extra-patch-LP1551075
  head/mail/mailman/files/patch-LP1551075
  head/mail/mailman/files/pkg-message.in
Comment 2 Matthias Andree freebsd_committer 2016-03-10 19:52:29 UTC
Thanks for the report, the issue is supposed to be resolved as of SVN r410774/PORTREVISION 4; the LP patch is now an extra patch that is only applied if HTDIG is disabled.  Sorry for the inconvenience.