Bug 208359 - [NEW PORT]: science/libflatarray: Struct of arrays library with object oriented interface for C++
Summary: [NEW PORT]: science/libflatarray: Struct of arrays library with object orient...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Shaun Amott
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-28 11:23 UTC by Kurt Kanzenbach
Modified: 2016-07-14 22:29 UTC (History)
2 users (show)

See Also:


Attachments
libflatarray port shell archive (5.70 KB, text/plain)
2016-03-28 11:23 UTC, Kurt Kanzenbach
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Kanzenbach 2016-03-28 11:23:57 UTC
Created attachment 168727 [details]
libflatarray port shell archive

LibFlatArray acts as a highly efficient multi-dimensional array of
arbitrary objects (array of structs, AoS), but really uses a struct of
arrays (SoA) memory layout. It's great for writing vectorized code and
its lightning-fast iterators give you access to neighboring elements
with zero address generation overhead.

WWW: http://www.libgeodecomp.org/libflatarray.html
Comment 1 Dmitry Marakasov freebsd_committer 2016-04-15 13:48:08 UTC
===>   Returning to build of libflatarray-0.2.0
Errors with dependencies.
*** Error code 1

Stop.
make: stopped in /usr/ports/science/libflatarray
Comment 2 Kurt Kanzenbach 2016-04-19 19:25:30 UTC
(In reply to Dmitry Marakasov from comment #1)

Thanks for the review. Actually I cannot reproduce that error. What did you do excactly to encounter the error? I've been using poudriere testport for building and testing the port.
Comment 3 commit-hook freebsd_committer 2016-07-14 22:25:39 UTC
A commit references this bug:

Author: shaun
Date: Thu Jul 14 22:25:28 UTC 2016
New revision: 418562
URL: https://svnweb.freebsd.org/changeset/ports/418562

Log:
  New port: devel/libflatarray.

  LibFlatArray acts as a highly efficient multi-dimensional array of
  arbitrary objects (array of structs, AoS), but really uses a struct of
  arrays (SoA) memory layout. It's great for writing vectorized code and
  its lightning-fast iterators give you access to neighboring elements
  with zero address generation overhead.

  PR:		ports/208359
  Submitted by:	kurt@kmk-computers.de

Changes:
  head/devel/Makefile
  head/devel/libflatarray/
  head/devel/libflatarray/Makefile
  head/devel/libflatarray/distinfo
  head/devel/libflatarray/files/
  head/devel/libflatarray/files/patch-examples_performance__tests_main.cpp
  head/devel/libflatarray/files/patch-src_aligned__allocator.hpp
  head/devel/libflatarray/pkg-descr
  head/devel/libflatarray/pkg-plist
Comment 4 Shaun Amott freebsd_committer 2016-07-14 22:29:27 UTC
Port added, thanks. I put this under devel as I'm not convinced it's specialised enough to warrant being in science.