Bug 209353 - [MAINTAINER][PATCH] net/freeswitch: update to freeswitch-1.6.8
Summary: [MAINTAINER][PATCH] net/freeswitch: update to freeswitch-1.6.8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-05-07 02:50 UTC by corsmith
Modified: 2016-05-19 18:54 UTC (History)
2 users (show)

See Also:


Attachments
freeswitch-1.6.8 svn diff (23.46 KB, patch)
2016-05-07 02:50 UTC, corsmith
no flags Details | Diff
full contents of extrapatch-modules.conf (5.72 KB, patch)
2016-05-09 00:36 UTC, corsmith
no flags Details | Diff
Update to 1.6.8 (7.19 KB, patch)
2016-05-17 11:39 UTC, Šimun Mikecin
no flags Details | Diff
svn diff (8.10 KB, patch)
2016-05-17 12:28 UTC, Šimun Mikecin
no flags Details | Diff
freeswitch-1.6.8 svn diff version 2 (24.46 KB, patch)
2016-05-18 00:57 UTC, corsmith
no flags Details | Diff
svn diff for patch-configure that allows configure to find lua5.3 (832 bytes, patch)
2016-05-19 13:37 UTC, corsmith
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description corsmith 2016-05-07 02:50:05 UTC
Created attachment 170077 [details]
freeswitch-1.6.8 svn diff

Maintainer update to freeswitch 1.6.8

svn diff attached.  The following svn commands were used before the diff was created:

svn remove files/patch-src_mod_applications_mod__http__cache_mod__http__cache.c
svn remove files/patch-src_mod_event__handlers_mod__rayo_xmpp__streams.c
svn move files/patch-modules.conf files/extrapatch-modules.conf

Changes included in update:

* Updated from 1.6.7 to 1.6.8
* Removed unnecessary patches
* explicitly depend on perl5 with USES
* Added ALL_MODULES knob to apply the extrapatch to modules.conf to enable all modules that successfully build on FreeBSD and their associated dependencies
* modules are now installed stripped
* cleaned-up the MASTER_SITES:N functionality for sounds
* mod_avmd no longer builds on FreeBSD - Will work with upstream to fix for next release

The previous version of the port would enable every module that would build on FreeBSD.  This version of the port builds the standard set of modules unless the ALL_MODULES knob is enabled.  The previous behaviour is restored when ALL_MODULES is enabled.

This allows the standard freeswitch user on FreeBSD to have a much smaller installation footprint and attack surface.  Power users can get a tested "batteries included" build by simply enabling the ALL_MODULES knob at build time.

Using the standard modules.conf means that lame is not a dependency which means fresh installs of FreeBSD can simply "pkg install freeswitch" in the future and be up and running in minutes.  This fails today because of the lame dependency which can not be distributed as a binary due to patent restrictions.
Comment 1 Kurt Jaeger freebsd_committer 2016-05-07 08:18:03 UTC
Can you check the files/extrapatch-modules.conf ? It's not in the current freeswitch port, so the patch fails to apply cleanly ?
Comment 2 corsmith 2016-05-09 00:36:35 UTC
Created attachment 170126 [details]
full contents of extrapatch-modules.conf
Comment 3 corsmith 2016-05-09 00:37:53 UTC
(In reply to Kurt Jaeger from comment #1)

The original was called patch-modules.conf.  I ran this command before making the svn diff:

svn move files/patch-modules.conf files/extrapatch-modules.conf

I attached the full contents of the file to the ticket for your reference.
Comment 4 Kurt Jaeger freebsd_committer 2016-05-09 05:32:21 UTC
(In reply to corsmith from comment #3)
Thanks, got it, testbuilding right now.
Comment 6 Šimun Mikecin 2016-05-11 09:21:35 UTC
Could you please remove dependency on openssl port?
Explained in:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=209196
Comment 7 Kurt Jaeger freebsd_committer 2016-05-11 10:54:49 UTC
testbuilds with the WITH_OPENSSL_PORT line removed @work.
Comment 8 corsmith 2016-05-12 22:03:54 UTC
(In reply to Kurt Jaeger from comment #7)
The build will complete but the ssl support will not be enabled.  You will notice in the test build log that the ssl library is not found in the configure phase.

The openssl port is required because the configure uses pkg-config to determine if the library exists and what the build options are.  The system openssl does not install an openssl.pc file so pkg-config fails to detect it.  An upstream patch for configure would be required for freeswitch to detect the system openssl.
Comment 10 Šimun Mikecin 2016-05-13 08:04:46 UTC
Regarding removing openssl port dependency:

Please, look at my last comment in:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=209196
Comment 11 Kurt Jaeger freebsd_committer 2016-05-13 17:35:46 UTC
So, what's next ? We have a 1.6.8 which does not build -- any ideas on how to get it building in poudriere ?
Comment 12 Šimun Mikecin 2016-05-17 11:39:54 UTC
Created attachment 170402 [details]
Update to 1.6.8

Update to 1.6.8 with configurable lame support and removed dependency on openssl port.
Comment 13 Šimun Mikecin 2016-05-17 12:28:46 UTC
Created attachment 170404 [details]
svn diff

Update to 1.6.8 with configurable lame support and removed dependency on openssl port (corrected previous attachment).
Comment 14 corsmith 2016-05-18 00:31:50 UTC
(In reply to numisemis from comment #13)
The distinfo changes are not acceptable as they remove all of the other language files.

I will re-upload an original version of my diff with the WITH_OPENSSL_PORT option removed.
Comment 15 corsmith 2016-05-18 00:35:51 UTC
(In reply to Kurt Jaeger from comment #11)

It looks like replies in email form do not make it back into the case in bugzilla.

I built the version sent with the svn diff under poudriere.

The AMD64/10.3-RELEASE build is failing due to a pkg-plist error:
http://people.freebsd.org/~pi/logs/net__freeswitch-103-1462772464.txt

Are you sure you are using my copy of the pkg-plist I sent in the patch?

The i386/10.3-RELEASE fails as expected (only builds on AMD64)
http://people.freebsd.org/~pi/logs/net__freeswitch-10i-1462772464.txt

Not sure about AMD64/9.3-RELEASE.  I'm guessing it is CLANG vs GCC problem.  We already have BROKEN_FreeBSD_9=       Fails in configure due to compiler issues
http://people.freebsd.org/~pi/logs/net__freeswitch-93a-1462772464.txt
Comment 16 corsmith 2016-05-18 00:57:53 UTC
Created attachment 170420 [details]
freeswitch-1.6.8 svn diff version 2

freeswitch-1.6.8 svn diff - version 2

Maintainer update to freeswitch 1.6.8

svn diff attached.  The following svn commands were used before the diff was created:

svn remove files/patch-src_mod_applications_mod__http__cache_mod__http__cache.c
svn remove files/patch-src_mod_event__handlers_mod__rayo_xmpp__streams.c
svn move files/patch-modules.conf files/extrapatch-modules.conf
svn add files/patch-src_mod_applications_mod__avmd_avmd__fast__acosf.c

Changes included in update:

* Updated from 1.6.7 to 1.6.8
* Removed unnecessary patches
* explicitly depend on perl5 with USES
* Added ALL_MODULES knob to apply the extrapatch to modules.conf to enable all modules that successfully build on FreeBSD and their associated dependencies
* modules are now installed stripped
* cleaned-up the MASTER_SITES:N functionality for sounds
* mod_avmd patch from numisemis@yahoo.com added

The previous version of the port would enable every module that would build on FreeBSD.  This version of the port builds the standard set of modules unless the ALL_MODULES knob is enabled.  The previous behaviour is restored when ALL_MODULES is enabled.

This allows the standard freeswitch user on FreeBSD to have a much smaller installation footprint and attack surface.  Power users can get a tested "batteries included" build by simply enabling the ALL_MODULES knob at build time.

Using the standard modules.conf means that lame is not a dependency which means fresh installs of FreeBSD can simply "pkg install freeswitch" in the future and be up and running in minutes.  This fails today because of the lame dependency which can not be distributed as a binary due to patent restrictions.
Comment 17 Kurt Jaeger freebsd_committer 2016-05-18 04:39:16 UTC
testbuilds@work
Comment 19 corsmith 2016-05-19 13:37:40 UTC
Created attachment 170482 [details]
svn diff for patch-configure that allows configure to find lua5.3

Attached is a patch to configure to allow it to find lua5.3.  The current default lua version is 5.2 and the build works in this case without the patch.
Comment 20 corsmith 2016-05-19 13:39:26 UTC
(In reply to Kurt Jaeger from comment #18)
This appears to be caused by a non-standard DEFAULT_VERSIONS=lua=5.3 in the testbuild environment.  If lua5.3 support is required then please add the attached additional configure patch to enable.
Comment 21 Kurt Jaeger freebsd_committer 2016-05-19 18:52:18 UTC
(In reply to corsmith from comment #20)
Done, looks very nice! Thanks!
Comment 22 Kurt Jaeger freebsd_committer 2016-05-19 18:54:15 UTC
Committed, thanks!
Comment 23 commit-hook freebsd_committer 2016-05-19 18:54:21 UTC
A commit references this bug:

Author: pi
Date: Thu May 19 18:54:03 UTC 2016
New revision: 415524
URL: https://svnweb.freebsd.org/changeset/ports/415524

Log:
  net/freeswitch: 1.6.7 -> 1.6.8

  - Removed unnecessary patches
  - explicitly depend on perl5 with USES
  - Added ALL_MODULES knob to apply the extrapatch to modules.conf
    to enable all modules that successfully build on FreeBSD and their
    associated dependencies
  - modules are now installed stripped
  - cleaned-up the MASTER_SITES:N functionality for sounds
  - mod_avmd no longer builds on FreeBSD - Will work with upstream to
    fix for next release

  PR:		209353
  Submitted by:	corsmith@gmail.com (maintainer)
  Reviewed by:	numisemis@yahoo.com

Changes:
  head/net/freeswitch/Makefile
  head/net/freeswitch/distinfo
  head/net/freeswitch/files/extrapatch-modules.conf
  head/net/freeswitch/files/patch-configure
  head/net/freeswitch/files/patch-modules.conf
  head/net/freeswitch/files/patch-src_mod_applications_mod__avmd_avmd__fast__acosf.c
  head/net/freeswitch/files/patch-src_mod_applications_mod__http__cache_mod__http__cache.c
  head/net/freeswitch/files/patch-src_mod_event__handlers_mod__rayo_xmpp__streams.c
  head/net/freeswitch/pkg-plist