Bug 209501 - graphics/zathura: Doesn't reload pdf when it changes
Summary: graphics/zathura: Doesn't reload pdf when it changes
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL: https://bugs.pwmt.org/project/zathura...
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2016-05-14 14:56 UTC by Zsolt Udvari
Modified: 2020-10-16 14:57 UTC (History)
5 users (show)

See Also:
bugzilla: maintainer-feedback? (quentin.stievenart)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zsolt Udvari 2016-05-14 14:56:09 UTC
I'm working with LaTeX-documents and I'm using zathura to view the generated pdf. But when I recompile the .tex file zathura doesn't reload the modified pdf.
Comment 1 quentin.stievenart 2016-05-23 06:18:22 UTC
Latest version of zathura is 0.3.6, current port is 0.3.4. Unfortunately, I'm not able to perform my maintainer role currently, and as such cannot test an update of the port.

You can see whether this problem is fixed by updating the port description to 0.3.6 and recompile it.
Comment 2 Zsolt Udvari 2016-05-23 10:43:56 UTC
The version 0.2.6 doesn't work too :(

I think the problem maybe isn't zathura-specific because graphics/apvlv doesn't reload automatically (the 'autoreload' is set to 1 - https://github.com/naihe2010/apvlv/blob/master/apvlvrc.example).
Comment 3 freebsd 2016-07-31 12:41:53 UTC
Stumbled upon this one, too.
Compiled LaTeX from within NeoVim (using vimtex to open previewer), and zathura doesn't recognise changes to the pdf file due to recompiling. But when I swap it out from under its arse by removing the file, then recompiling it, it works. So you can't just update the file in place, you have to rm it first, then create a new one for zathura to see changes.
If this isn't unique to zathura, might it be an issue in the OS/filesystem? In that case: running 10.3-p6 with ZFS.
Comment 4 VK freebsd_triage 2016-09-24 23:28:16 UTC
Link to upstream issue.

https://bugs.pwmt.org/project/zathura/issue/639
Comment 5 freebsd 2016-10-25 23:15:53 UTC
This might actually be an issue in glib. Zathura uses this to detect changes in files. fuse-sshfs also depends on glib, and I see a very similar problem there: sshfs fails to recognise a change in a remote file, so from the sshfs-client the file seems unchanged. Glib seems a common factor here.
Comment 6 Walter Schwarzenfeld freebsd_triage 2018-01-17 07:16:18 UTC
We have version 0.3.8. Is this still relevant?
Comment 7 Zsolt Udvari 2018-01-17 07:53:24 UTC
(In reply to w.schwarzenfeld from comment #6)
Yes.
Comment 8 Nathan 2018-08-25 20:20:21 UTC
(In reply to Zsolt Udvari from comment #7)
Have you tried the latest version 0.4.0 to see if it will do this? I don't use this port, so unsure how to use it to reproduce this error
Comment 9 Zsolt Udvari 2018-08-25 20:26:20 UTC
(In reply to Nathan from comment #8)
I'm using quarterly repository so I can't try it now.

Steps to reproduce:
1. Install TeXLive.
2. Create a simple (La)TeX-file (for example https://en.wikibooks.org/wiki/LaTeX/Basics#The_LaTeX_syntax) and run pdf(la)tex on it to generate a pdf file.
3. Open the generated pdf file in zathura.
4. Change the (La)TeX-file (created in step 2) and recompile it. The pdf file is changed but zathura doesn't reload it.
Comment 10 Nathan 2018-08-25 20:27:29 UTC
Ok, will attempt to see if I can reproduce this bug ASAP with latest version
Comment 11 freebsd 2018-08-25 20:55:57 UTC
(In reply to Nathan from comment #8)
Using zathura 0.4.0, I just compiled a TeX-file, opened it in zathura, then changed it. After recompiling the pdf, zathura did not pick it up automatically, I had to hit "r".
Comment 12 Zsolt Udvari 2018-08-25 20:58:59 UTC
(In reply to freebsd from comment #11)
Exactly :)
Comment 13 Mark Linimon freebsd_committer freebsd_triage 2020-08-02 03:38:58 UTC
^Triage: assign to a @FreeBSD.org address.

To maintainer: this PR looks old.  Is it still relevant?
Comment 14 quentin.stievenart 2020-08-02 07:51:50 UTC
It is indeed old, but has been a problem for 2 years at least, so it may still be relevant. At least it impacted 0.4.0, and we are now at 0.4.6, and I don't see an explicit reference to solving this problem in the changelog since then.

The upstream bug URL is broken though, and the bug does not seem to be listed in the new bugtracker of the project (https://git.pwmt.org/pwmt/zathura).
If someone can reproduce the bug, it would probably be better to notify the zathura team about it.
Comment 15 Zsolt Udvari 2020-08-02 12:52:26 UTC
Yes, it's still exist.
Comment 16 Zsolt Udvari 2020-10-16 14:57:02 UTC
It seems works now. I close this ticket.