Bug 209526 - devel/ncurses: Fix installed .pc file to use -Wl,-rpath rather than -rpath
Summary: devel/ncurses: Fix installed .pc file to use -Wl,-rpath rather than -rpath
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kubilay Kocak
URL:
Keywords: patch
Depends on:
Blocks: 178732
  Show dependency treegraph
 
Reported: 2016-05-15 19:29 UTC by John Hein
Modified: 2016-10-22 07:11 UTC (History)
5 users (show)

See Also:
koobs: merge-quarterly+


Attachments
patch - specify -Wl,-rpath rather than -rpath in .pc file (779 bytes, patch)
2016-05-15 19:32 UTC, John Hein
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Hein 2016-05-15 19:29:29 UTC
As discussed in bug 178732 (currently in comments 4-15), specifying -rpath in the ncurses .pc breaks other ports.

The change to use -Wl,-rpath has been committed upstream and will be available when ncurses-6.1 comes out.  Until then, the port for ncurses-6.0 should apply a patch to configure to use -Wl,-rpath (and probably bump PORTREVISION so the "better" .pc is in place for other ports).
Comment 1 John Hein 2016-05-15 19:32:04 UTC
Created attachment 170328 [details]
patch - specify -Wl,-rpath rather than -rpath in .pc file
Comment 2 John Hein 2016-06-03 15:26:02 UTC
There's already feedback that this is the right change (bug 178732, 2016-02-18 comment from bapt), but I guess a separate bug didn't help move things forward.  Can this be handled with a feedback timeout?  I'd like to get this committed so the chain of PRs associated with this can be unblocked.
Comment 3 John Hein 2016-06-27 16:41:27 UTC
Track maintainer change.  Ping for possible action on feedback timeout.
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2016-06-27 16:53:04 UTC
Thanks John, can you provide confirmation of successful QA (portlint, poudriere) as well as an reference (commit, issue, mailing list) of the upstream resolution please

Port is unmaintained, reset assignee.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2016-06-27 16:53:32 UTC
Comment on attachment 170328 [details]
patch - specify -Wl,-rpath rather than -rpath in .pc file

Port is unmaintained, implicit approval
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2016-06-28 08:37:37 UTC
This might also be worth an exp-run
Comment 7 John Hein 2016-06-28 12:32:44 UTC
Upstream commit (slightly different arrangement than the patch in attachment 170328 [details] but equivalent effect):

http://lists.gnu.org/archive/html/bug-ncurses/2016-02/msg00009.html
 and
http://lists.gnu.org/archive/html/bug-ncurses/2016-02/msg00006.html

That is also mentioned in bug 178732 comment 14 (the discussion that spawned this bug) - that freebsd bug is mentioned in the upstream announcement.

When 6.1 is released and the ncurses port is updated for 6.1, this patch can be reverted.

I can confirm that this passes various QA tests:

 portlint - no new errors due to patch [1]

 testport - passes (tested on 9-stable/i386)

 stage-qa - passes
 
Triggering an exp-run is fine if you think this patch merits it.  I've been running with this in a number of ports trees that get regular build updates for 5+ months now - sort of an anecdotal partial exp-run.

[1] Existing portlint nitpicks could be fixed by a motivated committer, but are not relevant in the context of this PR.  If possible, please address those after committing this fix.
Comment 8 John Hein 2016-08-02 12:43:49 UTC
Request an exp-run.
Comment 9 Antoine Brodin freebsd_committer 2016-08-02 13:37:42 UTC
An exp-run won't show anything,  only 4 or 5 ports in the ports tree have USES= ncurses:port
By default the majority of ports use ncurses from base.
Comment 10 John Hein 2016-08-02 13:48:01 UTC
Ok.  Is there anything else needed to commit this?
Comment 11 John Hein 2016-09-12 05:17:51 UTC
Can someone commit this, please?  It's blocking another update.
Comment 12 Kubilay Kocak freebsd_committer freebsd_triage 2016-09-12 08:07:22 UTC
I'll take it John, apologies for the delay
Comment 13 commit-hook freebsd_committer 2016-10-22 07:06:13 UTC
A commit references this bug:

Author: koobs
Date: Sat Oct 22 07:05:56 UTC 2016
New revision: 424449
URL: https://svnweb.freebsd.org/changeset/ports/424449

Log:
  devel/ncurses: Fix pkg-config file for linking

  - Backport upstream patch from 20160220 [1]:

    modify configure macro for shared-library rules to use -Wl,-rpath
    rather than -rpath to work around a bug in scons (FreeBSD #178732 [2],
    cf: 20061021).

  While I'm here:

  - Remove unecessary CONFLICTS (on deleted port)
  - Add LICENSE_FILE
  - Tab -> space in pkg-descr: WWW URL

  [1] http://lists.gnu.org/archive/html/bug-ncurses/2016-02/msg00009.html
  [2] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=178732

  PR:		209526
  Submitted by:	John Hein <z7dr6ut7gs snkmail com>
  MFH:		2016Q4

Changes:
  head/devel/ncurses/Makefile
  head/devel/ncurses/files/
  head/devel/ncurses/files/patch-configure
  head/devel/ncurses/pkg-descr
Comment 14 commit-hook freebsd_committer 2016-10-22 07:09:16 UTC
A commit references this bug:

Author: koobs
Date: Sat Oct 22 07:08:45 UTC 2016
New revision: 424450
URL: https://svnweb.freebsd.org/changeset/ports/424450

Log:
  MFH: r424449 - devel/ncurses: Fix pkg-config file for linking

  - Backport upstream patch from 20160220 [1]:

    modify configure macro for shared-library rules to use -Wl,-rpath
    rather than -rpath to work around a bug in scons (FreeBSD #178732 [2],
    cf: 20061021).

  While I'm here:

  - Remove unecessary CONFLICTS (on deleted port)
  - Add LICENSE_FILE
  - Tab -> space in pkg-descr: WWW URL

  [1] http://lists.gnu.org/archive/html/bug-ncurses/2016-02/msg00009.html
  [2] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=178732

  PR:		209526
  Submitted by:	John Hein <z7dr6ut7gs snkmail com>

  Approved by:	ports-secteam (blanket)

Changes:
_U  branches/2016Q4/
  branches/2016Q4/devel/ncurses/Makefile
  branches/2016Q4/devel/ncurses/files/
  branches/2016Q4/devel/ncurses/pkg-descr
Comment 15 Kubilay Kocak freebsd_committer freebsd_triage 2016-10-22 07:11:03 UTC
Committed & merged (2016Q4) with minor additions/changes.

Thank you to everyone involved and for following this through to complete (upstream) resolution.