Bug 209837 - net/rsync: [patch] fix popt library selection
Summary: net/rsync: [patch] fix popt library selection
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Emanuel Haupt
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-05-29 14:27 UTC by Martin Birgmeier
Modified: 2016-06-22 07:21 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ehaupt)


Attachments
patch to net/rsync/Makefile to fix option POPT_PORT handling (428 bytes, patch)
2016-05-29 14:27 UTC, Martin Birgmeier
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Birgmeier 2016-05-29 14:27:40 UTC
Created attachment 170791 [details]
patch to net/rsync/Makefile to fix option POPT_PORT handling

The net/rsync port does not handle the option POPT_PORT=off correctly. The attached patch fixes this.

-- Martin
Comment 1 Emanuel Haupt freebsd_committer 2016-06-02 07:24:08 UTC
You're right, the popt option logic is completely broken. However, the patch does not fix it in the right way.

There are a few things wrong:

- POPT_CONFIGURE_WITH should actually be POPT_PORT_CONFIGURE_WITH
- The whole ^POPT block logic is reversing the logic

I'm going to commit a patch shortly.
Comment 2 commit-hook freebsd_committer 2016-06-02 07:36:43 UTC
A commit references this bug:

Author: ehaupt
Date: Thu Jun  2 07:35:50 UTC 2016
New revision: 416270
URL: https://svnweb.freebsd.org/changeset/ports/416270

Log:
  Fix the logic of the POPT_PORT option.

  - POPT_CONFIGURE_WITH should actually be POPT_PORT_CONFIGURE_WITH
  - The whole ^POPT block logic is reversing the logic
  - Bump PORTREVISION since we have a change of dependencie

  PR:		209837 (based on)
  Submitted by:	Martin Birgmeier <la5lbtyi@aon.at>
  MFH:		2016Q2

Changes:
  head/net/rsync/Makefile
Comment 3 Martin Birgmeier 2016-06-02 17:15:20 UTC
I think the new fix is only valid if you reverse the description of the POPT_PORT option.

If not, my fix should have been correct (the problem is that there is no POPT_PORT_CONFIGURE_WITH*OUT* option).

-- Martin
Comment 4 Martin Birgmeier 2016-06-02 17:29:26 UTC
One more note: if you reverse the meaning of the POPT_PORT option, preexisting options files will suddenly result in the opposite.