Bug 210021 - ports-mgmt/porttools: "port test" fails on some ports because of missing build dependencies
Summary: ports-mgmt/porttools: "port test" fails on some ports because of missing buil...
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: VK
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2016-06-04 13:43 UTC by VK
Modified: 2019-12-18 10:11 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (skreuzer)


Attachments
Output of running "port test" in /usr/ports/www/nginx (7.98 KB, text/plain)
2016-06-04 13:43 UTC, VK
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description VK freebsd_triage 2016-06-04 13:43:12 UTC
Created attachment 171005 [details]
Output of running "port test" in /usr/ports/www/nginx

Running "port test" on some ports fails at the configure stage for missing dependencies. Attached is an example with nginx, but I've noticed it with some other ports as well.

This happens in a clean new 10.3 jail, updated to -p5, with the ports tree checked out from SVN head, having the required tools installed from "latest" pkg repo: subversion, vim-lite, ca_root_nss and of course porttools. Forgot dialog4ports but running this build pulled it in. Used default options.

Ran port test with -L because portlint was complaining about spaces vs tabs for this particular Makefile but fixing those two fatals didn't change the failure. Installing pcre via pkg allowed "port test" to complete without error.

Otherwise installing the port with regular "make install" inside the port dir pulls in all the deps and builds fine.
Comment 1 Steven Kreuzer freebsd_committer 2016-06-06 23:39:22 UTC
Does this only happen if you are in a 10.3 jail. I did some quick testing and I have been unable to reproduce the issue you are seeing (but I haven't been doing this in a 10.3 jail)
Comment 2 VK freebsd_triage 2016-06-07 00:09:36 UTC
Thanks for the feedback. Nope, not only in a jail, and not only in a svn checked out tree. I just tried on the jail host in /usr/ports obtained by portsnap. No pcre installed, running "port test" in /usr/ports/www/nginx fails for the same reason.
Comment 3 VK freebsd_triage 2016-11-26 16:49:22 UTC
I can't replicate this any more, for quite a while now, I'm closing. I'll reopen if I see it again. Assign to self because I close.
Comment 4 commit-hook freebsd_committer 2019-12-18 10:11:02 UTC
A commit references this bug:

Author: lme
Date: Wed Dec 18 10:10:48 UTC 2019
New revision: 520379
URL: https://svnweb.freebsd.org/changeset/ports/520379

Log:
  Fix dependency syntax

  PR:		210021
  Submitted by:	fluffy@
  Reported by:	mat@

Changes:
  head/net-mgmt/icingaweb2-module-businessprocess/Makefile
  head/net-mgmt/icingaweb2-module-cube/Makefile
  head/net-mgmt/icingaweb2-module-director/Makefile
  head/net-mgmt/icingaweb2-module-elasticsearch/Makefile
  head/net-mgmt/icingaweb2-module-fileshipper/Makefile
  head/net-mgmt/icingaweb2-module-generictts/Makefile
  head/net-mgmt/icingaweb2-module-grafana/Makefile
  head/net-mgmt/icingaweb2-module-graphite/Makefile
  head/net-mgmt/icingaweb2-module-idoreports/Makefile
  head/net-mgmt/icingaweb2-module-ipl/Makefile
  head/net-mgmt/icingaweb2-module-map/Makefile
  head/net-mgmt/icingaweb2-module-pdfexport/Makefile
  head/net-mgmt/icingaweb2-module-reactbundle/Makefile
  head/net-mgmt/icingaweb2-module-reporting/Makefile
  head/net-mgmt/icingaweb2-module-vsphere/Makefile