Bug 210443 - Update for devel/qtcreator to 4.0.2
Summary: Update for devel/qtcreator to 4.0.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-21 19:15 UTC by Marie Loise Nolden
Modified: 2016-06-23 13:18 UTC (History)
3 users (show)

See Also:
pi: maintainer-feedback+


Attachments
Qt Creator 4.0.2 update against svn HEAD diff (19.18 KB, patch)
2016-06-21 19:15 UTC, Marie Loise Nolden
no flags Details | Diff
Qt Creator 4.0.2 update against svn HEAD diff (18.70 KB, patch)
2016-06-22 05:09 UTC, Marie Loise Nolden
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marie Loise Nolden 2016-06-21 19:15:53 UTC
Created attachment 171656 [details]
Qt Creator 4.0.2 update against svn HEAD diff

Update for QtCreator to 4.0.2.

During the update to 4.0.1 (see https://blog.qt.io/blog/2016/06/08/qt-creator-4-0-1-released/) a bug was detected that led to the "Run" buttons being disabled to start a project program binary and also led to the debugger not finding the executable on 10.x and 11 systems using clang while on 9.3 the issue did not appear. The cause was detected and fixed in co-work with the Qt Creator developers, see

https://bugreports.qt.io/browse/QTCREATORBUG-16462

and the fix included as a patchset in this port in

https://codereview.qt-project.org/#/c/163090/
Comment 1 Kurt Jaeger freebsd_committer 2016-06-22 04:41:16 UTC
Fails to build on 9.3a:

http://people.freebsd.org/~pi/logs/devel__qtcreator-93a-1466548394.txt
Comment 2 Marie Loise Nolden 2016-06-22 05:09:00 UTC
Created attachment 171663 [details]
Qt Creator 4.0.2 update against svn HEAD diff
Comment 3 Marie Loise Nolden 2016-06-22 05:10:04 UTC
Hi Kurt,

I accidentally commented out the define needed for gcc systems in the Makefile, corrected that now. Please use the new diff.
Comment 4 Kurt Jaeger freebsd_committer 2016-06-22 05:30:18 UTC
looks better on 9.3a, still building.
Comment 5 Kurt Jaeger freebsd_committer 2016-06-22 06:20:15 UTC
Committed, thanks!
Comment 6 commit-hook freebsd_committer 2016-06-22 06:20:17 UTC
A commit references this bug:

Author: pi
Date: Wed Jun 22 06:19:55 UTC 2016
New revision: 417291
URL: https://svnweb.freebsd.org/changeset/ports/417291

Log:
  devel/qtcreator: 4.0.1 -> 4.0.2

  During the update to 4.0.1 a bug was detected that led to the "Run"
  buttons being disabled to start a project program binary and also
  led to the debugger not finding the executable on 10.x and 11 systems
  using clang while on 9.3 the issue did not appear. The cause was
  detected and fixed in co-work with the Qt Creator developers, see

  https://bugreports.qt.io/browse/QTCREATORBUG-16462

  and the fix included as a patchset in this port in

  https://codereview.qt-project.org/#/c/163090/

  PR:		210443
  Submitted by:	Ralf Nolden <nolden@kde.org> (kde)

Changes:
  head/devel/qtcreator/Makefile
  head/devel/qtcreator/distinfo
  head/devel/qtcreator/files/
  head/devel/qtcreator/files/patch-src_plugins_android_android.pro
  head/devel/qtcreator/files/patch-src_plugins_android_android.qbs
  head/devel/qtcreator/files/patch-src_plugins_android_androiddevice.cpp
  head/devel/qtcreator/files/patch-src_plugins_android_androidrunnable.cpp
  head/devel/qtcreator/files/patch-src_plugins_android_androidrunnable.h
  head/devel/qtcreator/files/patch-src_plugins_debugger_analyzer_analyzerstartparameters.h
  head/devel/qtcreator/files/patch-src_plugins_debugger_debuggerplugin.cpp
  head/devel/qtcreator/files/patch-src_plugins_projectexplorer_customwizard_customwizard.cpp
  head/devel/qtcreator/files/patch-src_plugins_projectexplorer_devicesupport_desktopdevice.cpp
  head/devel/qtcreator/files/patch-src_plugins_projectexplorer_devicesupport_idevice.cpp
  head/devel/qtcreator/files/patch-src_plugins_projectexplorer_runconfiguration.h
  head/devel/qtcreator/files/patch-src_plugins_projectexplorer_runnables.cpp
  head/devel/qtcreator/files/patch-src_plugins_projectexplorer_runnables.h