Bug 210717 - Unable to install ALPHA5 on T420 w/ ZFS+GELI+GPT
Summary: Unable to install ALPHA5 on T420 w/ ZFS+GELI+GPT
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-sysinstall mailing list
URL:
Keywords:
: 210815 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-30 05:41 UTC by Eli Boaz
Modified: 2016-07-08 05:20 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eli Boaz 2016-06-30 05:41:36 UTC
Installation aborts when selecting ZFS on root install (T420, SSD) with message:

/mnt/boot

ZFS Configuration:
Type/Disks: Stripe w/ 1 disk
Pool: rivendell
4K Sectors: yes
Encryption: yes
Partition: GPT(BIOS+UEFI)
Swap size: 8G
Encrypt Swap: yes

Configure GELI password
Initializing encryption on selected disks
GEOM_ELI messages (XTS, AES256, Hardware)

mkdir: /mnt/boot: no such file or directory

This has reproduced across several install attempts to my T420 (240GB SSD) using FreeBSD-11.0-ALPHA5-amd64-20160624-r302164-memstick.img.

Also tried:
GPT + Lenovo Fix: Same result
Auto UFS: Works
Auto ZFS on GPT(Bios+UEFI) and no GELI: Works
Comment 1 Allan Jude freebsd_committer 2016-07-02 05:25:27 UTC
Can you switch to console #3 (control+alt+f3) and look for debugging messages? Or use the shell on console #4 to copy the bsdinstall_log off of the temporary disk and attach it here?
Comment 2 commit-hook freebsd_committer 2016-07-03 01:23:23 UTC
A commit references this bug:

Author: allanjude
Date: Sun Jul  3 01:22:59 UTC 2016
New revision: 302319
URL: https://svnweb.freebsd.org/changeset/base/302319

Log:
  Fix an error in bsdinstall when ZFS installation uses a bootpool

  A separate bootpool is used when the selected partition type is MBR
  or when the disk is GELI encrypted and a UEFI loader is selected.

  BIOS avoids the bootpool by using bootcode and loader that support GELI.

  bsdinstall did not remount the bootpool after creating the main pool,
  which caused an error when mkdir tried to create /boot/zfs

  PR:		210717
  Approved by:	re (gjb)
  Sponsored by:	ScaleEngine Inc.

Changes:
  head/usr.sbin/bsdinstall/scripts/zfsboot
Comment 3 Allan Jude freebsd_committer 2016-07-03 01:24:43 UTC
This fix will be included in the next release, BETA1 expected this coming Friday
Comment 4 Allan Jude freebsd_committer 2016-07-05 14:40:10 UTC
*** Bug 210815 has been marked as a duplicate of this bug. ***
Comment 5 Jonathan Anderson freebsd_committer 2016-07-07 16:16:15 UTC
I applied this patch to the installer as it ran and it fixed the problem for me. Thanks!
Comment 6 Allan Jude freebsd_committer 2016-07-07 16:16:57 UTC
The fix will be included in the next build, which should come out tonight or tomorrow. Sorry for the issue.
Comment 7 Eli Boaz 2016-07-08 05:20:20 UTC
Thank you, Allan! I was able to grab the updated zfsroot script and confirmed your update does fix the existing RC5 image as BETA1 wasn't out. Sorry, I didn't get you the debug info - I did not see the bug update until tonight.