Bug 211001 - HP Proliant: BIOS problem with 3TB+ disks
Summary: HP Proliant: BIOS problem with 3TB+ disks
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.0-RELEASE
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL: https://wiki.freebsd.org/HPBIOS3TBHDD
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-07-11 09:46 UTC by Julien Cigar
Modified: 2018-04-22 16:12 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Cigar 2016-07-11 09:46:50 UTC
I just installed a fresh 10.3-RELEASE on an HP Proliant MicroServer Gen8 and came across this issue https://wiki.freebsd.org/HPBIOS3TBHDD .. Apparently it was already discovered on 10.1-RELEASE but I can't find any bug report so I add this one. I have exactly the same error as in the wiki link and the patch seems to work here .. Would it be possible to merge it in the next release ? Thanks :)
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2016-07-13 17:53:25 UTC
See wiki page for patch.
Comment 2 Julien Cigar 2017-01-09 18:15:53 UTC
Just tried 11-RELEASE today and the problem is still there, the machine doesn't boot. Apparently it's an issue with the HP BIOS, but the following patch worked for 10 https://github.com/kuriyama/freebsd/compare/freebsd:stable/10...hp-bios-workaround-10.diff
Comment 3 Franz Bettag 2017-04-18 07:06:12 UTC
Maybe we could get this into base? I have a bunch of "these" HP Servers running FreeBSD and it's really time consuming to forget to cp zfsloader to /boot/ after running freebsd-update, and then having to remotely fix that (as all of them are a few hundred kilometers away).

Since i didn't see anything breaking on other systems, maybe this can be merged?
Comment 4 Eugene Grosbein freebsd_committer 2018-04-22 16:12:58 UTC
The patch has been committed to head as r331718 and has been MFC'd to stable/11 as r332056, prior to the release of 11.2.