Bug 211202 - www/chromium : repeated "Ah snap; Something went wrong" went browsing
Summary: www/chromium : repeated "Ah snap; Something went wrong" went browsing
Status: Closed DUPLICATE of bug 204454
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-chromium (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-18 16:10 UTC by bourne.identity@hotmail.com
Modified: 2018-02-07 09:13 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (chromium)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bourne.identity@hotmail.com 2016-07-18 16:10:05 UTC
I am using FreeBSD 10.2 amd64. The system works perfectly. My default browser is Firefox, which works very well. I keep chromium as my alternate browser. But when browsing sites like BBC/Amazon, chrome keeps producing page-load errors with the message "Ah snap; something went wrong" for pages being loaded, roughly once for every 3-4 pages loaded. Deleting and reinstalling the package have not helped.

Since the rest of the FreeBSD system is working perfectly, I must assume that this is a problem with the www/chromium port.
Comment 1 Arto Pekkanen 2016-07-19 18:35:46 UTC
(In reply to bourne.identity@hotmail.com from comment #0)

This PR is most probably a duplicate of https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=204454

And yes, the problem is with the www/chromium port or one of it's dependencies. When I tried to debug the problem I found out that SIGSEGV happened somewhere in libstdc++. Did not have enough knowledge and/or skills to debug it any further.

Btw debugging www/chromium is problematic because the size of the debug binary is over 4 Gigabytes. In order to debug, one must build the debug binary separately, run the original with gdb, and instruct gdb to fetch debug symbols from the debug binary.
Comment 2 Walter Schwarzenfeld freebsd_triage 2018-01-18 16:32:46 UTC
10.2 is EOL. We have newer versions of chromium. Is this problem still present?
Comment 3 Grzegorz Junka 2018-01-18 17:04:24 UTC
This is still very much an issue for me, to such extent that I have to use Firefox instead of Chrome. I am on FreeBSD 11.1. I haven't tried the latest quarterly ports but the issue has been present for year and it's unlikely that it has been fixed by accident. This is not happening in Windows or on Linux so I suspect the issue is with FreeBSD-specific patches.
Comment 4 Grzegorz Junka 2018-02-07 08:20:56 UTC
Since this defect is likely a duplicate of https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=204454 and the earlier defect is more broad and has more comments, is there any way in Bugzilla to link those two?
Comment 5 Walter Schwarzenfeld freebsd_triage 2018-02-07 09:13:43 UTC

*** This bug has been marked as a duplicate of bug 204454 ***