Bug 211835 - Boot environment selection from loader menu does not work on 10.3
Summary: Boot environment selection from loader menu does not work on 10.3
Status: Closed DUPLICATE of bug 208601
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 10.3-RELEASE
Hardware: Any Any
: --- Affects Some People
Assignee: Allan Jude
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-14 10:55 UTC by Victor Sudakov
Modified: 2016-09-09 15:01 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Sudakov 2016-08-14 10:55:46 UTC
If you create a BE with sysutils/beadm-devel and try to boot into this BE via the loader menu (Option 7), the system will never boot fully.

There will be numerous errors like

ip6addrctl: fopen: /dev/stdin: No such file or directory
swapon: /dev/vtbd0p2: No such file or directory
ps: empty file: Invalid argument

and you will never see the login prompt. Your only option is to reboot.

Superficiously it looks like /dev is missing when booting into an alternative BE.

My zfs filesystem layout is standard (created by bsdinstall in the "Auto ZFS" mode).

I would be happy to provide any additional info required to debug the problem.
Comment 1 Victor Sudakov 2016-08-21 15:20:28 UTC
Mike, have you been able to reproduce it?
Comment 2 Brandon Wandersee 2016-08-21 21:08:33 UTC
I can confirm this behavior on 10.3-RELEASE-p7, with sysutils/beadm (as opposed to sysutils/beadm-devel). Boot environments created and activated in user space work just fine, but a boot environment selected from the loader menu (UEFI with vt(4) in my case) will not boot in either single- or multi-user mode.
Comment 3 Victor Sudakov 2016-08-22 15:08:41 UTC
If I boot into single user mode after selecting an non-default BE in the loader menu, I see a discrepancy:


# mount
zroot/ROOT/test1 on / (zfs, local, noatime, read-only, nfsv4acls)
devfs on /dev (devfs, local, multilabel)
# zpool get bootfs zroot
NAME   PROPERTY  VALUE               SOURCE
zroot  bootfs    zroot/ROOT/default  local
# 

Is it really normal? Looks suspicious to me.
Comment 4 Allan Jude freebsd_committer 2016-09-09 15:00:41 UTC
The problem was that / from a different boot environment was being mounted over top of the selected BE, and masking /dev

This was fixed by a commit to upstream beadm this morning.

The port will be updated soon.
Comment 5 Allan Jude freebsd_committer 2016-09-09 15:01:31 UTC

*** This bug has been marked as a duplicate of bug 208601 ***