Bug 212042 - devel/py-pytest: Update to 3.0.0
Summary: devel/py-pytest: Update to 3.0.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-python (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-22 06:57 UTC by Yuri Victorovich
Modified: 2016-12-29 15:03 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (python)


Attachments
patch (2.70 KB, patch)
2016-08-22 06:57 UTC, Yuri Victorovich
no flags Details | Diff
patch (2.75 KB, patch)
2016-08-22 18:34 UTC, Yuri Victorovich
no flags Details | Diff
patch (2.75 KB, patch)
2016-08-22 21:12 UTC, Yuri Victorovich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2016-08-22 06:57:12 UTC
Created attachment 173927 [details]
patch

Patch under files/ is deleted because it was applied upstream.

Passes poudriere on 10.3 amd64.

'make test' fails with an obscure error 245:  https://github.com/pytest-dev/pytest/issues/1838
This isn't a regression because tests for 2.8.7 also fail in the same module, but with a different code 246.
Comment 1 Yuri Victorovich freebsd_committer 2016-08-22 18:34:20 UTC
Created attachment 173955 [details]
patch
Comment 2 Yuri Victorovich freebsd_committer 2016-08-22 21:12:47 UTC
Created attachment 173958 [details]
patch

'make test' (see above) failure turned out to be spurious.

But there is one test that fails: https://github.com/pytest-dev/pytest/issues/1845
IMO, it can still be committed as it is.
Comment 3 Kurt Jaeger freebsd_committer 2016-09-13 19:11:26 UTC
testbuilds are ok on 12a, 11a, 10i, 9.3a.

make test on ports-version 2.8.7:

collected 1327 items 
[...]
 37 failed, 1253 passed, 10 skipped, 27 xfailed, 2 pytest-warnings in 140.37 seconds

make test on submitted version 3.0.0:

collected 1691 items 
[...]
 50 failed, 1605 passed, 7 skipped, 29 xfailed, 4 pytest-warnings in 176.84 seconds

What now ?
Comment 4 commit-hook freebsd_committer 2016-10-14 00:32:17 UTC
A commit references this bug:

Author: wen
Date: Fri Oct 14 00:31:17 UTC 2016
New revision: 423944
URL: https://svnweb.freebsd.org/changeset/ports/423944

Log:
  - Update to 3.0.3
  - Update TEST_DEPENDS

  PR:		212042 (based on)
  Submitted by:	yuri@rawbw.com

Changes:
  head/devel/py-pytest/Makefile
  head/devel/py-pytest/distinfo
  head/devel/py-pytest/files/
Comment 5 Wen Heping freebsd_committer 2016-10-14 00:46:24 UTC
56 failed in 3.0.3 version but 1614 passed so I committed this patch.
Sorry no time to check all failed tests.

wen