Bug 212196 - devel/swig30: Revert upstream commit 75510a1 (breaks irc/znc with clang)
Summary: devel/swig30: Revert upstream commit 75510a1 (breaks irc/znc with clang)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Many People
Assignee: Dmitry Marakasov
URL: https://github.com/swig/swigissues/615
Keywords: needs-patch, patch, regression
Depends on:
Blocks:
 
Reported: 2016-08-27 14:12 UTC by Chris Rees
Modified: 2016-10-05 18:44 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (sunpoet)
koobs: merge-quarterly?


Attachments
Revert problematic commit (57 bytes, text/plain)
2016-08-27 14:12 UTC, Chris Rees
no flags Details
Another patch variant (2.31 KB, patch)
2016-09-11 14:42 UTC, Dmitry Marakasov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Rees freebsd_committer 2016-08-27 14:12:03 UTC
Created attachment 174125 [details]
Revert problematic commit

A GCC 6 fix for swig causes the errors found here https://www.bayofrum.net/pkg/110amd64-system/2016-08-26_18h47m55s/logs/errors/znc-1.6.3_2.log

This patch reverts the commit.

Upstream issue; https://github.com/swig/swig/issues/615

Cheers!
Comment 1 Chris Rees freebsd_committer 2016-08-27 14:13:43 UTC
Auto assign fail!
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2016-08-27 14:49:06 UTC
Thanks Chris, could you replace attachment 174125 [details] (contains a URL to bayofrum.net/~crees/patches) with the patch itself please.

There's a minor typo in the patch comment itself, "swigissues/615" (404) should be "swig/issues/615"

Also for whoever commits this, if you could include a reference to the upstream issue url in the commit log message, it will add a comment to the github issue, allowing users to see what happened downstream.

FWIW, I believe this change comes under blanket/implicit approval, not needing maintainer approval (if tested/QA'd).
Comment 3 Chris Rees freebsd_committer 2016-08-27 15:26:09 UTC
Hi Koobs,

It is tested, but only with znc/clang- Sunpoet may wish to test with other combinations, so this is a courtesy.

I'll upload the patch when I'm on a computer, not a tablet- that's the reason it didn't attach properly last time.

Chris
Comment 4 Dmitry Marakasov freebsd_committer 2016-09-11 14:42:38 UTC
Created attachment 174653 [details]
Another patch variant

Here's another solution, it doesn't revert the commit, but addresses the problem (missing header) directly.

Upstream issue https://github.com/swig/swig/pull/788 (sorry, I haven't noticed there was an issue already).

While here, the patch
- Fixes lincese
- Removes obsolete REINPLACE (malloc.h is not in swig code for years)
- Silences stuff which should be silenced
Comment 5 Chris Rees freebsd_committer 2016-09-11 17:10:39 UTC
Hi Dmitry,

Much better solution, thanks.  We're actually past two weeks for timeout purposes anyway, so I think you should commit your fix if you know it fixes znc.

Chris
Comment 6 Dmitry Marakasov freebsd_committer 2016-09-11 17:27:39 UTC
Maintainer timeout
Comment 7 commit-hook freebsd_committer 2016-09-11 17:41:13 UTC
A commit references this bug:

Author: amdmi3
Date: Sun Sep 11 17:40:43 UTC 2016
New revision: 421850
URL: https://svnweb.freebsd.org/changeset/ports/421850

Log:
  - Add missing include to generated code, fixing build of irc/znc
  - Fix LICENSE and add LICENSE_FILE
  - Remove long obsolete REINPLACE_CMD
  - Silence patching and stipping

  Upstream bugreport for reference: https://github.com/swig/swig/pull/788

  PR:		212196
  Submitted by:	crees, amdmi3
  Approved by:	maintainer timeout (sunpoet, 2 weeks)

Changes:
  head/devel/swig30/Makefile
  head/devel/swig30/files/patch-Lib_typemaps_fragments.swg