Bug 212822 - Cannot set console font on FreeBSD 11.0-RC3
Summary: Cannot set console font on FreeBSD 11.0-RC3
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 11.0-RC1
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords: regression, vt
Depends on:
Blocks:
 
Reported: 2016-09-19 11:40 UTC by Sergey
Modified: 2016-11-03 11:34 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey 2016-09-19 11:40:51 UTC
Hello.

On FreeBSD 11.0-RC3 I'm not able to set console fonts anymore while I was able to do so on 10.3 with vt driver.

# vidcontrol -f vgarom-8x14     - works fine on FreeBSD 10.3 and changes the fonts

# vidcontrol -f vgarom-8x14     - doesn't work on FreeBSD 11.0-RC3
PIO_VFONT: Operation not supported
vidcontrol: failed to load font "vgarom-8x14": Operation not supported

I'm experimenting inside VirtualBox 5.0.0

Also for some reason FreeBSD 10.3 uses higher console resolution, while 11.0-RC3 uses only test mode:
# dmesg | grep VT              - FreeBSD 10.3
VT(vga): resolution 640x480

# dmesg | grep VT              - FreeBSD 11.0-RC3
VT(vga): text 80x25

Also for some reason FreeBSD 10.3 uses terminus like console font by default,  while 11.0-RC3 uses font vga 8x16 or resembling.
Comment 1 Sergey 2016-09-20 06:55:56 UTC
Following options have been set inside GENERIC file both for FreeBSD 10.3 and FreeBSD 11.0-RC3:

#device          vga                     # VGA video card driver
#options         VESA                    # Add support for VESA BIOS Extensions (VBE)

#device          splash                  # Splash screen and screen saver support

# syscons is the default console driver, resembling an SCO console
#device         sc
#options        SC_PIXEL_MODE           # add support for the raster text mode

# vt is the new video console driver
device          vt
device          vt_vga
device          vt_efifb
options         TERMINAL_NORM_ATTR=(FG_LIGHTGREY|BG_BLACK)
options         TERMINAL_KERN_ATTR=(FG_RED|BG_BLACK)

device          agp                     # support several AGP chipsets
Comment 2 pilot513 2016-10-18 17:00:29 UTC
On FreeBSD 11.0-Release I'm not to set console fonts too ...
Comment 3 Nike 2016-11-02 20:26:58 UTC
(In reply to Sergey from comment #0)

I solved the problem:

echo "hw.vga.textmode=0" >> /boot/loader.conf
Comment 4 Sergey 2016-11-03 11:34:13 UTC
The issue is solved.