Bug 213291 - [NEW PORT] audio/ardour5: latest version of the Ardour DAW
Summary: [NEW PORT] audio/ardour5: latest version of the Ardour DAW
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on: 213287 213288 213289 213290
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-07 20:15 UTC by Michael Beer
Modified: 2017-01-12 21:41 UTC (History)
4 users (show)

See Also:


Attachments
new port (24.62 KB, text/plain)
2016-10-07 20:15 UTC, Michael Beer
no flags Details
update of new port ardour5 (334 bytes, text/plain)
2016-11-24 14:45 UTC, Michael Beer
no flags Details
Update to Ardour 5.5.0 (22.81 KB, text/plain)
2016-12-01 20:54 UTC, Michael Beer
no flags Details
Original + fixes, see description (22.91 KB, text/plain)
2017-01-08 23:56 UTC, Yuri Victorovich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Beer 2016-10-07 20:15:26 UTC
Created attachment 175515 [details]
new port

Ardour - the digital audio workstation.

WWW: https://ardour.org/

This is the latest version of Ardour.
There is already v2 of Ardour in the ports.
ardour5 can either replace the existing ardour port or
live in parallel.
Comment 1 Marcel Bonnet 2016-11-17 14:20:45 UTC
Shouldn't you add dependencies to "Depends on" list?  213285 (lv2), 213287 (sord), 213288 (sratom), 213289 (suil), 213290 (lilv) .

I think you'll need another MASTER_SITE : this URL points to every new release of the upstream. So, when they launch 5.5, all our tries to download 5.4 will break.

I ported Ardour 5.3 (and all dependencies too). If you want some ideia to make the distfile available (for free), see my Makefile : https://github.com/marcelbonnet/freebsd-ports/blob/master/audio/ardour5/Makefile

I don't know why, but github break when trying to download a tag from ardour/Ardour. So I made another repo, put only the files needed to 5.3 (there is no history files, it is not a clone), this way the port system finds a tag in this repo and can fetch it.

IMHO, port committers should keep audio/ardour (version 2) in parallel. It is very simple, lightweight, useful for old machines or simple projects.
Comment 2 Marcel Bonnet 2016-11-17 14:30:13 UTC
Related to PR 214605 (NEW PORT: multimedia/harvid) and PR 214604 (NEW PORT: multimedia/xjadeo)

These ports helps Ardour5 to draw a still frame video timeline (harvid) and play the related video in sync with Ardour music editing (xjadeo player), as long as Ardour uses JACK, instead of internal, time source/transport.
Comment 3 Michael Beer 2016-11-24 14:45:14 UTC
Created attachment 177358 [details]
update of new port ardour5

Changed MASTERSIDE as the upstream size only has the latest source tarball available.
Made Makefile more generic.
Comment 4 Michael Beer 2016-11-24 14:52:59 UTC
(In reply to Marcel Bonnet from comment #1)
Thanks, for your input.
I had a chat with the ardour devs regarding the github issue you mentioned.
It seems to be an issue of github itself. They are not going to make a workaround for this as they anyway want users to update ASAP when a new version is out.
Therefore I'm now hosting the tar ball on my github account.
Comment 5 Michael Beer 2016-12-01 20:54:27 UTC
Created attachment 177581 [details]
Update to Ardour 5.5.0

Update to new Ardour release 5.5.0
Comment 6 Yuri Victorovich freebsd_committer 2017-01-08 18:42:38 UTC
The build fails for me:
> /usr/bin/ld: /usr/local/lib/libsmf.a(libsmf_la-smf.o): relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC
> /usr/local/lib/libsmf.a: could not read symbols: Bad value
c++: error: linker command failed with exit code 1 (use -v to see invocation)
Comment 7 Yuri Victorovich freebsd_committer 2017-01-08 18:49:47 UTC
Also I think you may want to add configure option --cxx11 and USES=compiler:c++11 because arch does this.
Comment 8 Yuri Victorovich freebsd_committer 2017-01-08 18:51:12 UTC
Also,

> --also-include=/usr/local/include --also-libdir=/usr/local/lib
should be converted to ${LOCALBASE}
Comment 9 Yuri Victorovich freebsd_committer 2017-01-08 23:56:28 UTC
Created attachment 178647 [details]
Original + fixes, see description

* Fixed dependency origin
* Added CONFLICTS_BUILD=libsmf because libsmf is bundled and the build uses port when it is present
* USES=gettext
* Replaced /usr/local with ${LOCALBASE}

Now it passes poudriere, along with all new port dependencies.
Comment 10 Michael Beer 2017-01-09 14:58:00 UTC
(In reply to Yuri Victorovich from comment #7)
The build works aswell with the configure option --cxx11 and USES=compiler:c++11-lang.
Comment 11 Michael Beer 2017-01-10 10:09:11 UTC
(In reply to Yuri Victorovich from comment #6)
I installed libsmf on my system but can't reproduce the linking issue.
Build still works without problems. Tested on FBSD 10.3 x64.
Comment 12 Yuri Victorovich freebsd_committer 2017-01-10 10:18:24 UTC
I saw a problem on 11 amd64.
Comment 13 Kurt Jaeger freebsd_committer 2017-01-11 06:33:15 UTC
Testbuild on 10.3p10-i386 fails, see

http://people.freebsd.org/~pi/logs/audio__ardour5-10i-1484077814.txt
Comment 14 Yuri Victorovich freebsd_committer 2017-01-11 06:54:59 UTC
Kurt,

Can you just add "BROKEN_FreeBSD_10=does not build due to the missing SSE options" and commit, until somebody will find the fix?

Yuri
Comment 15 Michael Beer 2017-01-11 20:53:21 UTC
(In reply to Yuri Victorovich from comment #12)
OK, I can reproduce the bug with 11 aswell. But wondering why the behaviour
where to look first for libsmf has changed from 10 to 11.
Comment 16 Kurt Jaeger freebsd_committer 2017-01-11 20:57:58 UTC
Tested on 10.3a, it build OK. Testing on 11i right now.
Comment 17 Yuri Victorovich freebsd_committer 2017-01-11 21:01:43 UTC
(In reply to Michael Beer from comment #15)
Several other packages suffer from the same problem (pick pre-installed package). For example, SQLiteStudio, llvm. This is related to the tendency to add -I and -L flags to the end of the command lines. It's best to label them as CONFLICTS. It's better yet to unbundle and use the standard version of the package if possible.
Comment 18 Michael Beer 2017-01-11 21:19:16 UTC
(In reply to Yuri Victorovich from comment #14)

Adding something like this should fix the build for i386:

.include <bsd.port.pre.mk>

.if ${ARCH} == "i386"
WITH_ARCH_FLAGS=	--arch='-msse -mfpmath=sse' --dist-target=i386
.elif ${ARCH} == "amd64"
WITH_ARCH_FLAGS=	--arch='-msse -mfpmath=sse' --dist-target=x86_64
.endif

.if defined(WITH_ARCH_FLAGS)
CONFIGURE_ARGS+=	${WITH_ARCH_FLAGS}
.endif

.include <bsd.port.post.mk>
Comment 19 Yuri Victorovich freebsd_committer 2017-01-11 21:21:30 UTC
You should verify this.(In reply to Michael Beer from comment #18)
You should verify this.
Comment 20 Kurt Jaeger freebsd_committer 2017-01-12 06:33:55 UTC
(In reply to Michael Beer from comment #18)
Tested both on 11i and 10i, looks fine.
Comment 21 Michael Beer 2017-01-12 08:39:14 UTC
(In reply to Kurt Jaeger from comment #20)
I've just tested both i386 and amd64 builds on 10.3
and can confirm that both work.
Comment 22 Yuri Victorovich freebsd_committer 2017-01-12 18:19:46 UTC
Please also close bug#180171
Comment 23 commit-hook freebsd_committer 2017-01-12 21:35:16 UTC
A commit references this bug:

Author: pi
Date: Thu Jan 12 21:34:38 UTC 2017
New revision: 431322
URL: https://svnweb.freebsd.org/changeset/ports/431322

Log:
  New port: audio/ardour5

  Ardour is a digital audio workstation. You can use it to record, edit, and
  mix multi-track audio. Produce your own CD's. Mix video soundtracks.
  Experiment with new ideas about music and sound. Generate sound
  installations for 12 speaker gallery shows.

  Ardour capabilities include: multichannel recording, non-linear, non-
  destructive region based editing with unlimited undo/redo, full automation
  support, a mixer whose capabilities rival high end hardware consoles, lots
  of plugins to warp, shift, and shape your music, and controllable from
  hardware control surfaces at the same time as it syncs to timecode. If you
  have been looking for a tool similar to ProTools, Nuendo, Cubase SX, Digital
  Performer, Samplitude, or Sequoia, you might have found it.

  WWW: https://ardour.org/

  PR:		213291
  Submitted by:	Michael Beer <beerml@sigma6audio.de>
  Reviewed by:	Yuri Victorovich <yuri@rawbw.com>

Changes:
  head/audio/Makefile
  head/audio/ardour5/
  head/audio/ardour5/Makefile
  head/audio/ardour5/distinfo
  head/audio/ardour5/files/
  head/audio/ardour5/pkg-descr
  head/audio/ardour5/pkg-plist
Comment 24 Kurt Jaeger freebsd_committer 2017-01-12 21:36:55 UTC
Thanks all for the work! Committed!
Comment 25 Yuri Victorovich freebsd_committer 2017-01-12 21:41:58 UTC
(In reply to Kurt Jaeger from comment #24)
Thank you, Kurt!