Bug 214242 - FreeBSD Kernel does not boot on Opteron_G4 CPU (KVM Guest)
Summary: FreeBSD Kernel does not boot on Opteron_G4 CPU (KVM Guest)
Status: Closed DUPLICATE of bug 213155
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.0-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-11-05 14:10 UTC by Samuel Husky
Modified: 2018-03-12 11:30 UTC (History)
5 users (show)

See Also:


Attachments
Archive containing screenshots described in report (58.85 KB, application/x-zip-compressed)
2016-11-05 14:10 UTC, Samuel Husky
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Husky 2016-11-05 14:10:27 UTC
Created attachment 176657 [details]
Archive containing screenshots described in report

I have reproduced this across a couple of guests now. One was an upgrade from 10.3-RELEASE (Which works fine) the other is the bootonly installer image

All hang immediately after the boot menu (Shown in bootloader.png)

Attempts to enable verbose debugging do not produce any further output.

Removal of:

<cpu mode='host-model'>
    <model fallback='allow'/>
</cpu>

From the libvirt XML allows the guest to boot with limited available instruction sets (Shown in kvmlimited.png) this would lead me to believe that a change in the 11 kernel has made it incompatible with a particular instruction set that is present on an Opteron 6234 CPU

Guest boots fine using host-model CPU of an Intel E5 2620 (SandyBridge) host (Shown in intelhost.png)

FreeBSD 10.3-RELEASE loads fine using the host-model parameters of KVM on the Opteron_G4 host (Shown in Opteron_G4 Features.png)

KVM / Qemu version of both hypervisors is 'QEMU emulator version 2.0.0 (Debian 2.0.0+dfsg-2ubuntu1.28)' and both hypervisors are running Ubuntu 14.04.5 LTS with libvirt 1.2.2

Libvirt XML of non-working:

<domain type='kvm' id='42'>
  <name>www</name>
  <uuid>fef0689e-fe23-df7c-1d11-3aa3447d6491</uuid>
  <description>None</description>
  <memory unit='KiB'>524288</memory>
  <currentMemory unit='KiB'>524288</currentMemory>
  <vcpu placement='static'>2</vcpu>
  <resource>
    <partition>/machine</partition>
  </resource>
  <os>
    <type arch='x86_64' machine='pc-i440fx-trusty'>hvm</type>
    <boot dev='hd'/>
    <boot dev='cdrom'/>
    <bootmenu enable='yes'/>
  </os>
  <cpu mode='host-model'>
    <model fallback='allow'/>
  </cpu>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/bin/kvm-spice</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source file='/var/lib/libvirt/images/www.img'/>
      <target dev='vda' bus='virtio'/>
      <alias name='virtio-disk0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </disk>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='/mnt/iso/FreeBSD-11.0-RELEASE-amd64-bootonly.iso'/>
      <target dev='hda' bus='ide'/>
      <readonly/>
      <alias name='ide0-1-1'/>
      <address type='drive' controller='0' bus='1' target='0' unit='1'/>
    </disk>
    <controller type='usb' index='0'>
      <alias name='usb0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x2'/>
    </controller>
    <controller type='pci' index='0' model='pci-root'>
      <alias name='pci.0'/>
    </controller>
    <controller type='ide' index='0'>
      <alias name='ide0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
    </controller>
    <interface type='bridge'>
      <mac address='52:54:00:21:33:01'/>
      <source bridge='br0'/>
      <target dev='vnet4'/>
      <model type='virtio'/>
      <alias name='net0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </interface>
    <serial type='pty'>
      <source path='/dev/pts/9'/>
      <target port='0'/>
      <alias name='serial0'/>
    </serial>
    <console type='pty' tty='/dev/pts/9'>
      <source path='/dev/pts/9'/>
      <target type='serial' port='0'/>
      <alias name='serial0'/>
    </console>
    <input type='tablet' bus='usb'>
      <alias name='input0'/>
    </input>
    <input type='mouse' bus='ps2'/>
    <input type='keyboard' bus='ps2'/>
    <graphics type='vnc' port='5904' autoport='yes' listen='0.0.0.0'>
      <listen type='address' address='0.0.0.0'/>
    </graphics>
    <video>
      <model type='cirrus' vram='9216' heads='1'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
    <memballoon model='virtio'>
      <alias name='balloon0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    </memballoon>
  </devices>
  <seclabel type='dynamic' model='apparmor' relabel='yes'>
    <label>libvirt-fef0689e-fe23-df7c-1d11-3aa3447d6491</label>
    <imagelabel>libvirt-fef0689e-fe23-df7c-1d11-3aa3447d6491</imagelabel>
  </seclabel>
</domain>
Comment 1 Samuel Husky 2016-11-05 14:16:25 UTC
I've just found that bug #213333 is a simlar issue.
Comment 2 Andriy Gapon freebsd_committer 2018-03-12 11:30:56 UTC
If you believe that this issue is different from bug #213333, then please re-open.

*** This bug has been marked as a duplicate of bug 213155 ***