Bug 214430 - sysutils/beadm: please update to latest to support loader menu (via 'noauto')
Summary: sysutils/beadm: please update to latest to support loader menu (via 'noauto')
Status: Closed DUPLICATE of bug 208601
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Bryan Drewery
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-11 23:03 UTC by eborisch+FreeBSD
Modified: 2018-01-18 20:31 UTC (History)
6 users (show)

See Also:
bugzilla: maintainer-feedback? (bdrewery)


Attachments
Patch zfs command line to use 'noauto' instead 'off' (523 bytes, patch)
2017-04-03 08:13 UTC, Goran Mekić
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description eborisch+FreeBSD 2016-11-11 23:03:44 UTC
Using the boot menu to select a boot environment is broken with the current beadm -- selecting anything other than the active one leaves ZFS trying to mount two systems on '/' (I believe is what is happening, at least; "failed to intialize ZFS library" is reported on the console) and the boot goes sideways.

This is because beadm is creating boot environments with canmount=yes, but the latest (on github) uses canmount=noauto; changed for this very issue: https://github.com/vermaden/beadm/pull/33

With 11.0 released, it would be helpful for beadm and the loader to play nicely together.
Comment 1 Graham Perrin 2017-04-02 05:28:41 UTC
Re: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=208601#c21 

* this bug 214430 may be a duplicate of bug 208601
Comment 2 Victor Sudakov 2017-04-02 05:51:14 UTC
(In reply to Graham Perrin from comment #1)
It is.
Comment 3 Goran Mekić 2017-04-03 08:13:11 UTC
Created attachment 181413 [details]
Patch zfs command line to use 'noauto' instead 'off'

I've tested this on my machine and it works. If there are any use/corner cases this patch breaks, please do tell!
Comment 4 Walter Schwarzenfeld freebsd_triage 2018-01-16 11:52:32 UTC
Maintainer feedback?
Comment 5 Bryan Drewery freebsd_committer 2018-01-18 20:23:42 UTC
We need an rc script to mount zfs datasets on boot before this change can go in for people like me who have children datasets like so:

# zfs list -r zroot/ROOT
NAME                                             USED  AVAIL  REFER  MOUNTPOINT
zroot/ROOT                                      25.0G  34.3G    31K  none
zroot/ROOT/releng_10.2-r287145                  25.0G  34.3G   415M  /
zroot/ROOT/releng_10.2-r287145/usr              14.5G  34.3G  1.47G  /usr
zroot/ROOT/releng_10.2-r287145/usr/dump          328M  34.3G   328M  /usr/dump
zroot/ROOT/releng_10.2-r287145/usr/local        4.00G  34.3G  1.93G  /usr/local
zroot/ROOT/releng_10.2-r287145/usr/local/share   954M  34.3G   205M  /usr/local/share
zroot/ROOT/releng_10.2-r287145/usr/obj          6.97G  34.3G  5.59G  /usr/obj
zroot/ROOT/releng_10.2-r287145/usr/src          1.45G  34.3G  1.18G  /usr/src
zroot/ROOT/releng_10.2-r287145/var              10.1G  34.3G   448M  /var
zroot/ROOT/releng_10.2-r287145/var/db           4.10G  34.3G   731M  /var/db
zroot/ROOT/releng_10.2-r287145/var/db/pkg        141M  34.3G  59.9M  /var/db/pkg
zroot/ROOT/releng_10.2-r287145/var/empty          32K  34.3G    31K  /var/empty
zroot/ROOT/releng_10.2-r287145/var/log           408M  34.3G   319M  /var/log
zroot/ROOT/releng_10.2-r287145/var/run          1.11M  34.3G  67.5K  /var/run
zroot/ROOT/releng_10.2-r287145/var/tmp            70K  34.3G    41K  /var/tmp
Comment 6 Bryan Drewery freebsd_committer 2018-01-18 20:31:50 UTC
Yes this is a duplicate of Bug 208601

*** This bug has been marked as a duplicate of bug 208601 ***