Bug 214461 - emulators/qemu-user-static use of undeclared identifier 'O_CLOEXEC'
Summary: emulators/qemu-user-static use of undeclared identifier 'O_CLOEXEC'
Status: Closed DUPLICATE of bug 214484
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sean Bruno
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-13 00:49 UTC by Walter Schwarzenfeld
Modified: 2016-11-13 18:22 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (sbruno)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Schwarzenfeld freebsd_triage 2016-11-13 00:49:27 UTC
Failed on 10.3-amd64 with
use of undeclared identifier 'O_CLOEXEC'

#define _GNU_SOURCE 1 does not help
I removed 'O_CLOEXEC' from line 308 in emulators/qemu-user-static/work/qemu-bsd-user-ec807d10/bsd-user/freebsd/os-proc.c.
(don't know if it is the right solution).
Comment 1 Sean Bruno freebsd_committer 2016-11-13 16:48:32 UTC
Huh ... this didn't happen on any of my poudriere jails when I built it.  I'll regress and see what's up.
Comment 2 Sean Bruno freebsd_committer 2016-11-13 18:22:27 UTC

*** This bug has been marked as a duplicate of bug 214484 ***