Bug 214607 - devel/libublio do not care MK_PROFILE variable
Summary: devel/libublio do not care MK_PROFILE variable
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Matthias Andree
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-17 14:32 UTC by Yasuhito FUTATSUKI
Modified: 2019-07-13 09:10 UTC (History)
1 user (show)

See Also:
mandree: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhito FUTATSUKI 2016-11-17 14:32:21 UTC
When I put 'MK_PROFILE=no' in /etc/make.conf, the devel/libublio port don't build libublio_p.a, but searchs for it on make install or make package and fails, because PROFLIB variable is set for "", not "@comment ".

Putting "NO_PROFILE=true" into /etc/make.conf instead makes it work, but make warns me "use MK_PROFILE=no instead."....
Comment 1 Yasuhito FUTATSUKI 2016-11-18 01:40:54 UTC
Some other ports have same problem also. converters/iconv, devel/libs11n, ...
Comment 2 Matthias Andree freebsd_committer 2017-03-21 23:06:44 UTC
Is this perhaps a framework issue, or regression, rather than a problem of individual ports?
Comment 3 Yasuhito FUTATSUKI 2017-03-23 07:03:45 UTC
(In reply to Matthias Andree from comment #2)
I think it has caused by lack of unified method of handling profile library which can be provided by ports in framework. 

Some port check NO_PROFILE variable in its port Makefile, others ask user to build proflib or not via make config, others set MAKE_ENV+= NO_PROFILE=yes in its port Makefile, but none checks MK_PROFILE variable. (I did egrep the ports tree with pattern '_p\.a$', 'PROFILE'.)
Comment 4 commit-hook freebsd_committer 2019-07-13 09:07:31 UTC
A commit references this bug:

Author: mandree
Date: Sat Jul 13 09:07:15 UTC 2019
New revision: 506527
URL: https://svnweb.freebsd.org/changeset/ports/506527

Log:
  Fix build with MK_PROFILE=no in make.conf

  PR:		214607
  Submitted by:	Yasuhito FUTATSUKI

Changes:
  head/devel/libublio/Makefile
Comment 5 commit-hook freebsd_committer 2019-07-13 09:10:35 UTC
A commit references this bug:

Author: mandree
Date: Sat Jul 13 09:09:33 UTC 2019
New revision: 506528
URL: https://svnweb.freebsd.org/changeset/ports/506528

Log:
  Fix build with MK_PROFILE=no in make.conf

  MFH: r506527

  Invoking blanket approval for fixing a broken build.

  PR:		214607
  Submitted by:	Yasuhito FUTATSUKI

  Approved by:	ports-secteam (blanket)

Changes:
_U  branches/2019Q3/
  branches/2019Q3/devel/libublio/Makefile