Bug 214703 - devel/icu: After upgrade to icu-58.1,1 other ports stop working and need recompilation
Summary: devel/icu: After upgrade to icu-58.1,1 other ports stop working and need reco...
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-office mailing list
URL:
Keywords:
Depends on:
Blocks: 214384
  Show dependency treegraph
 
Reported: 2016-11-21 14:00 UTC by chris
Modified: 2018-02-14 16:55 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chris 2016-11-21 14:00:25 UTC
After upgrade to icu-58.1,1 other ports stop working and need recompile. Please add to /usr/ports/UPDATING that you have to recompile ports depending on icu.
Comment 1 Jan Beich freebsd_committer 2016-11-21 22:57:29 UTC
Not enough details. How do you upgrade installed ports? Manually doing "make deinstall" + "make install" is not supported. Try using "pkg upgrade", ports-mgmt/synth or ports-mgmt/portmaster that properly track dependencies.

Every port with direct dependency on devel/icu had its PORTREVISION bumped which should've forced rebuild. UPDATING is for steps not covered by such bumps.
Comment 2 chris 2016-11-22 08:51:45 UTC
I upgrade the ports using `portupgrade -ay` . After the upgrade php complain for int.so and also postfix didn't work. I had to rebuild all ports to make them work (but I think it would work if I only rebuild ports depend on icu).
Comment 3 chris 2016-11-22 08:52:37 UTC
I upgrade the ports using `portupgrade -ay` . After the upgrade php complain for int.so and also postfix didn't work. I had to rebuild all ports to make them work (but I think it would work if I only rebuild ports depend on icu).
Comment 4 w.schwarzenfeld freebsd_triage 2018-01-12 12:13:54 UTC
The PR is one year old. We have icu version 60_2.
And the "problem" is the same each icu update. Some user "refuses" to recompile.....
I think this could closed.