Bug 215076 - print/lilypond-devel: Update to 2.19.57
Summary: print/lilypond-devel: Update to 2.19.57
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Raphael Kubo da Costa
URL:
Keywords: easy, needs-qa
Depends on:
Blocks: 218308
  Show dependency treegraph
 
Reported: 2016-12-05 18:02 UTC by m.ne
Modified: 2017-04-02 16:51 UTC (History)
4 users (show)

See Also:
riggs: maintainer-feedback+


Attachments
Patch for print/lilypond-devel to 2.19.52 (1.01 KB, patch)
2016-12-05 21:33 UTC, m.ne
no flags Details | Diff
Patch for print/lilypond-devel to 2.19.55 (3.79 KB, patch)
2017-02-17 16:27 UTC, m.ne
no flags Details | Diff
Patch for print/lilypond-devel to 2.19.56 (6.60 KB, patch)
2017-03-09 06:22 UTC, m.ne
no flags Details | Diff
Patch for print/lilypond-devel to 2.19.57 (6.80 KB, patch)
2017-03-16 18:06 UTC, m.ne
no flags Details | Diff
fs-violation log from poudriere (146.81 KB, application/x-xz)
2017-03-18 11:38 UTC, Thomas Zander
no flags Details
fs-violation log from poudriere on 10.3 i386 (91.02 KB, application/x-xz)
2017-03-19 13:05 UTC, Thomas Zander
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.ne 2016-12-05 18:02:02 UTC
Update print/lilypond-devel to latest version
Comment 1 m.ne 2016-12-05 21:33:35 UTC
Created attachment 177699 [details]
Patch for print/lilypond-devel to 2.19.52
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2016-12-06 04:54:06 UTC
Hi Martin, thanks for your submission. For this and future issues, please:

- Confirm the change (patch) passes QA (portlint & poudriere). For more information see: https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/testing.html

- Set the maintainer-approval flag to + on attachments for ports you are maintainer of. Attachment -> Details -> maintainer-approval [+]

- Don't CC the freebsd-ports mailing list, as new Ports & Package issues are already  automatically assigned to the freebsd-ports-bugs list.

- Setting maintainer-feedback flag to + is only required if it is set to ? first (which means asking the maintainer for feedback, which doesn't apply when the maintainer is the reporter)
Comment 3 Raphael Kubo da Costa freebsd_committer 2016-12-24 13:10:27 UTC
I tried building the patch here on Poudriere in a 12-HEAD jail and it failed:

configure: creating ./config.status
config.status: creating config.make
config.status: creating config.hh

WARNING: Please consider installing optional programs or files:  URW++ OTF fonts (download OTF files from 'http://git.ghostscript.com/?
p=urw-core35-fonts.git;a=commit;h=79bcdfb34fbce12b592cce389fa7a19da6b5b018' and put them under '~/.local/share/fonts' etc., or use --wi
th-urwotf-dir) gs >= 9.20 (installed: 9.16) extractpdfmark (Optionally using Ghostscript >= 9.20 together with Extract PDFmark can sign
ificantly reduce the disk space required for building the documentation and the final PDF files.)

ERROR: Please install required programs:  /usr/local/bin/fontforge >= 20110222 (installed: )

See INSTALL.txt for more information on how to build LilyPond
Comment 4 m.ne 2017-02-17 16:27:03 UTC
Created attachment 180084 [details]
Patch for print/lilypond-devel to 2.19.55
Comment 5 Raphael Kubo da Costa freebsd_committer 2017-02-18 11:30:47 UTC
The new patch also fails to build on Poudriere:

config.status: creating config.make
config.status: creating config.hh

WARNING: Please consider installing optional programs or files:  URW++ OTF fonts (download OTF files from 'http://git.ghostscript.com/?p=urw-core35-fonts.git;a=commit;h=79bcdfb34fbce12b592cce389fa7a19da6b5b018' and put them under '~/.local/share/fonts' etc., or use --with-urwotf-dir) gs >= 9.20 (installed: 9.16) extractpdfmark (Optionally using Ghostscript >= 9.20 together with Extract PDFmark can significantly reduce the disk space required for building the documentation and the final PDF files.)

ERROR: Please install required programs:  /usr/local/bin/fontforge >= 20110222 (installed: )

See INSTALL.txt for more information on how to build LilyPond
Comment 6 m.ne 2017-03-09 06:22:24 UTC
Created attachment 180664 [details]
Patch for print/lilypond-devel to 2.19.56
Comment 7 m.ne 2017-03-09 06:35:58 UTC
(In reply to Raphael Kubo da Costa from comment #5)
Hello Raphael,

Thanks for your feedback. Unfortunately I wasn't able to reproduce the problem (using poudriere-devel). Did you perhaps make some additional modification to the ports tree used by poudriere that might interfere with the build?

In any case it would be a great help if you could send me the full build log so I can see what's happening (or not happeninjg) until the point of failure.

Thanks in advance,
Martin
Comment 8 Raphael Kubo da Costa freebsd_committer 2017-03-11 23:37:21 UTC
I finally took some time to investigate this; the problem is that my jail is built with WITHOUT_GNU_GREP_COMPAT=yes, and STEPMAKE_GET_VERSION in aclocal.m4 uses extended regular expressions in a call to grep without passing -E, which breaks fontforge's version detection when grep(1) is built with the option I mentioned.

I tried it on 10.3 with a default grep(1) and the patch indeed worked.

By the way, have you tried removing MAKE_JOBS_UNSAFE? I've tried this on a jail with many cores and it worked fine, though the best would be passing a low -j number.
Comment 9 Thomas Zander freebsd_committer 2017-03-12 11:27:56 UTC
I am getting this from poudriere:

====>> Checking for filesystem violations... done
====>> Error: Filesystem touched during build:
extra: var/db/fontconfig/30f1f778d4121994232d6adf0fafd1af-le64.cache-7
build of print/lilypond-devel ended at Sun Mar 12 12:22:26 CET 2017

Could you take a look?
Comment 10 m.ne 2017-03-16 18:04:36 UTC
(In reply to Thomas Zander from comment #9)
Would mind sending me the full log? I just finished another run from poudriere which finished with no errors.
Comment 11 m.ne 2017-03-16 18:06:03 UTC
Created attachment 180883 [details]
Patch for print/lilypond-devel to 2.19.57
Comment 12 Thomas Zander freebsd_committer 2017-03-18 11:38:29 UTC
Created attachment 180923 [details]
fs-violation log from poudriere

Newest patch generates the same fs violation. Full log attached.
Comment 13 Raphael Kubo da Costa freebsd_committer 2017-03-19 11:59:37 UTC
I didn't get any errors here with in an 10.3-i386 jail. Does adding USES=fonts help your build pass?
Comment 14 Thomas Zander freebsd_committer 2017-03-19 12:28:47 UTC
(In reply to Raphael Kubo da Costa from comment #13)

Nope, same error, also reproducible on a 10.3 i386 poudriere jail.
You are running "poudriere testport", right?
Comment 15 Raphael Kubo da Costa freebsd_committer 2017-03-19 12:42:36 UTC
Right.
Comment 16 Thomas Zander freebsd_committer 2017-03-19 13:05:38 UTC
Created attachment 180960 [details]
fs-violation log from poudriere on 10.3 i386

Here is my poudriere log from 10.3 / i386 jail.
Can you check for differences in your log?
Comment 17 Raphael Kubo da Costa freebsd_committer 2017-03-19 13:17:48 UTC
Hmm, I tried building with poudriere instead of poudriere-devel and got the same filesystem violation error.
Comment 18 Raphael Kubo da Costa freebsd_committer 2017-03-19 13:19:03 UTC
+bdrewery. I wonder if this is a bug in the non-devel version of Poudriere.
Comment 19 Raphael Kubo da Costa freebsd_committer 2017-03-19 17:46:16 UTC
After some bisection, Poudriere stopped complaining once the BUILD_AS_NON_ROOT option's default became "yes". If I set it to "no", I get the same fontconfig error with a later version of Poudriere.
Comment 20 Bryan Drewery freebsd_committer 2017-03-19 20:12:55 UTC
(In reply to Thomas Zander from comment #9)
> I am getting this from poudriere:
> 
> ====>> Checking for filesystem violations... done
> ====>> Error: Filesystem touched during build:
> extra: var/db/fontconfig/30f1f778d4121994232d6adf0fafd1af-le64.cache-7
> build of print/lilypond-devel ended at Sun Mar 12 12:22:26 CET 2017
> 
> Could you take a look?

Is this with or without BUILD_AS_NON_ROOT? (yes or no?)

I think what is happening is that this cache is not generated either at fontconfig package creation time or installation time when building as non-root, and then when the build runs later the cache is generated unexpectedly.
Comment 21 Raphael Kubo da Costa freebsd_committer 2017-03-19 21:47:24 UTC
(In reply to Bryan Drewery from comment #20)
> (In reply to Thomas Zander from comment #9)
> > I am getting this from poudriere:
> > 
> > ====>> Checking for filesystem violations... done
> > ====>> Error: Filesystem touched during build:
> > extra: var/db/fontconfig/30f1f778d4121994232d6adf0fafd1af-le64.cache-7
> > build of print/lilypond-devel ended at Sun Mar 12 12:22:26 CET 2017
> > 
> > Could you take a look?
> 
> Is this with or without BUILD_AS_NON_ROOT? (yes or no?)

That's with BUILD_AS_NON_ROOT=no (the default in ports-mgmt/poudriere 3.1.15).

> I think what is happening is that this cache is not generated either at
> fontconfig package creation time or installation time when building as
> non-root, and then when the build runs later the cache is generated
> unexpectedly.

Would you say that's a bug in Poudriere or is there something we can do in the port itself?
Comment 22 Raphael Kubo da Costa freebsd_committer 2017-03-24 10:57:13 UTC
I've tried building lilypond-devel-2.19.51_1 (the version currently in ports) with BUILD_AS_NON_ROOT=no and got the same fontconfig error.

So given this update will not introduce a regression, I'm going to land it.
Comment 23 commit-hook freebsd_committer 2017-03-24 10:59:31 UTC
A commit references this bug:

Author: rakuco
Date: Fri Mar 24 10:58:50 UTC 2017
New revision: 436807
URL: https://svnweb.freebsd.org/changeset/ports/436807

Log:
  Update to 2.19.57.

  PR:		215076
  Submitted by:	m.ne@gmx.net (maintainer)

Changes:
  head/print/lilypond-devel/Makefile
  head/print/lilypond-devel/distinfo
  head/print/lilypond-devel/files/patch-Documentation_GNUmakefile
  head/print/lilypond-devel/files/patch-config.make.in
  head/print/lilypond-devel/files/patch-configure
  head/print/lilypond-devel/files/patch-flower_include_std-string.hh
  head/print/lilypond-devel/files/patch-flower_include_std-vector.hh
  head/print/lilypond-devel/files/patch-lily_include_lily-guile.hh
  head/print/lilypond-devel/files/patch-python_GNUmakefile
  head/print/lilypond-devel/files/patch-stepmake_stepmake_texinfo-vars.make
  head/print/lilypond-devel/pkg-plist