Bug 215526 - emulators/virtualbox-ose: Machine freeze with Linux guest
Summary: emulators/virtualbox-ose: Machine freeze with Linux guest
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: vbox (Nobody)
Depends on:
Reported: 2016-12-23 20:43 UTC by Will B
Modified: 2020-02-14 00:35 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (vbox)

VBoxSVC.log.1 (4.50 KB, text/plain)
2016-12-23 20:43 UTC, Will B
no flags Details
Guest machine log (86.37 KB, text/plain)
2016-12-23 20:44 UTC, Will B
no flags Details
Relevant dmesg excerpt (232 bytes, text/plain)
2016-12-23 20:46 UTC, Will B
no flags Details
Guest machine vbox config (6.19 KB, application/xml)
2016-12-23 21:00 UTC, Will B
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Will B 2016-12-23 20:43:53 UTC
Created attachment 178236 [details]

With a clean ~/.virtualbox, I installed Debian Jessie Linux (8) on virtualbox-ose version 5.1.6 r110634.  Either during the install of Debian or afterward the virtualbox guest partially freezes.  If running a desktop environment in the Debian guest, the clock applet in the panel still keeps proper time, but little else seems to respond.  The following comes up in the guest's log:

  00:25:36.638384 AioMgr0-N: Request 0x000008261b36c0 failed with rc=VERR_TRY_AGAIN, migrating endpoint /home/will/VirtualBox VMs/Debian Testing/Debian Testing.vdi to failsafe manager.
  00:25:36.900555 AIOMgr: I/O manager 0x0000082d5933a0 encountered a critical error (rc=VERR_FILE_AIO_NO_REQUEST) during operation. Falling back to failsafe mode. Expect reduced performance
  00:25:36.913330 AIOMgr: Error happened in /wrkdirs/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.1.6/src/VBox/VMM/VMMR3/PDMAsyncCompletionFileNormal.cpp:(1669){int pdmacFileAioMgrNormal(RTTHREAD, void *)}
  00:25:36.913333 AIOMgr: Please contact the product vendor

When I try to close the guest with 'Power off machine' (either by closing the guest's window or by closing in the vbox manager), a small dialog comes up estimating the time it will take to close the machine.  The machine never closes and the estimated time in the small dialog grows to hours.  I must issue a 'killall -SIGKILL VirtualBox' in order to successfully close the guest.

No special options are being used for the installation and use of the Debian guest machine.  I will attach the config file, along with any relevant logs.
Comment 1 Will B 2016-12-23 20:44:52 UTC
Created attachment 178237 [details]
Guest machine log
Comment 2 Will B 2016-12-23 20:46:27 UTC
Created attachment 178238 [details]
Relevant dmesg excerpt
Comment 3 Will B 2016-12-23 21:00:02 UTC
Created attachment 178239 [details]
Guest machine vbox config
Comment 4 Will B 2016-12-23 21:04:15 UTC
It appears on some of these freezes that the guest OS is still somewhat responsive, but there is a problem reading the disk.  Almost all commands that I enter into the guest's terminal return with "Input / Output error".  dmesg also returns the same error from the guest.
Comment 5 Will B 2016-12-23 21:30:45 UTC
Tests with Slackware 14.2 amd64 also yield the same issue.  So far, Windows XP guests don't have this issue.
Comment 6 Dmitri Goutnik freebsd_committer 2016-12-23 23:17:02 UTC
This seems like AIO issue, these adjustments might help: bug #168298, comment #3
Comment 7 Will B 2017-06-07 18:04:20 UTC
(In reply to Dmitri Goutnik from comment #6)

Thanks for the information Dmitri.

I have found that SATA virtual controllers need to have 'Use Host I/O Cache' enabled, then the freezes (mostly) go away.  

Virtual IDE controllers don't seem to need 'Use Host I/O Cache' enabled, however.
Comment 8 Graham Perrin 2019-09-21 16:01:41 UTC
Is this still an issue? With e.g. 5.2.32_1
Comment 9 Will B 2019-09-22 19:59:20 UTC
(In reply to Graham Perrin from comment #8)

Unfortunately I'm unable to run FreeBSD on my current hardware to check right now.  Last recent experience didn't seem to have issues with this as I already knew to set the virtual controller to 'Use host cache'.

Hopefully one day FreeBSD will support my hardware and I can use it again. :-)
Comment 10 jason-fbsd-bugzilla 2020-02-14 00:35:32 UTC
(In reply to Graham Perrin from comment #8)

I can confirm that this is still an issue as of 2020-02-13.

hashbrown/home/jason-124957: uname -a
FreeBSD hashbrown 12.1-STABLE FreeBSD 12.1-STABLE r357056 JKERN12  amd64

hashbrown/home/jason-124958: pkg info virtualbox\*         

I'm using a Fedora-31 guest, but saw identical symptoms to OP.  Enabling "Use Host I/O Cache" on the virtual SATA controller fixed it for me.

Let me know of any other info I can provide or testing I can do.