Bug 215689 - New port lang/cling : Interactive C++ compiler based on LLVM and Clang
Summary: New port lang/cling : Interactive C++ compiler based on LLVM and Clang
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Roman Bogorodskiy
URL: http://reviews.freebsd.org/D9012
Keywords: patch-ready
Depends on:
Blocks:
 
Reported: 2016-12-31 23:58 UTC by Mahdi Mokhtari
Modified: 2017-01-03 08:23 UTC (History)
1 user (show)

See Also:


Attachments
patch adds lang/cling to ports-tree (115.93 KB, patch)
2016-12-31 23:58 UTC, Mahdi Mokhtari
no flags Details | Diff
patch adds port + disabling libunwind build/link explicitly (116.63 KB, patch)
2017-01-01 12:19 UTC, Mahdi Mokhtari
no flags Details | Diff
new patch with some fixes reflecing review (123.28 KB, patch)
2017-01-02 12:42 UTC, Mahdi Mokhtari
no flags Details | Diff
new patch with some fixes reflecing review + PREFIX instead of LOCALBASE (123.28 KB, patch)
2017-01-02 12:57 UTC, Mahdi Mokhtari
no flags Details | Diff
Updated patch reflecting the last changes of review (omitting PORTVERSIONSUFFIX, ...) (123.19 KB, patch)
2017-01-02 15:14 UTC, Mahdi Mokhtari
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mahdi Mokhtari freebsd_committer freebsd_triage 2016-12-31 23:58:29 UTC
Created attachment 178425 [details]
patch adds lang/cling to ports-tree

I just created a patch that adds lang/cling to the port tree.
It builds successfully and works as intended.
Comment 1 Mahdi Mokhtari freebsd_committer freebsd_triage 2017-01-01 00:01:52 UTC
Opened a review for patch at [reviews.freebsd.org/D9012]
Comment 2 Mahdi Mokhtari freebsd_committer freebsd_triage 2017-01-01 00:02:50 UTC
portlint is okay.
tested with poudriere on 10.X jail, it's okay.
Comment 3 Mahdi Mokhtari freebsd_committer freebsd_triage 2017-01-01 12:19:02 UTC
Created attachment 178430 [details]
patch adds port + disabling libunwind build/link explicitly
Comment 4 Mahdi Mokhtari freebsd_committer freebsd_triage 2017-01-02 12:42:27 UTC
Created attachment 178447 [details]
new patch with some fixes reflecing review
Comment 5 Mahdi Mokhtari freebsd_committer freebsd_triage 2017-01-02 12:57:57 UTC
Created attachment 178448 [details]
new patch with some fixes reflecing review + PREFIX instead of LOCALBASE
Comment 6 Mahdi Mokhtari freebsd_committer freebsd_triage 2017-01-02 15:14:32 UTC
Created attachment 178450 [details]
Updated patch reflecting the last changes of review (omitting PORTVERSIONSUFFIX, ...)
Comment 7 commit-hook freebsd_committer 2017-01-03 08:07:56 UTC
A commit references this bug:

Author: novel
Date: Tue Jan  3 08:07:00 UTC 2017
New revision: 430442
URL: https://svnweb.freebsd.org/changeset/ports/430442

Log:
  Add lang/cling: Interactive C++ Interpreter Based on LLVM and Clang Libs

  Cling is an interactive C++ interpreter,
  built on the top of LLVM and Clang libraries.
  Its advantages over the standard interpreters are that it has command prompt
  and uses just-in-time (JIT) compiler for compilation.
  One of Cling's main goals is to provide contemporary, high-performance
  alternative of the current C++ interpreter in the ROOT project "CINT".
  The backward-compatibility with CINT is major priority during the development.

  Its main advantages are:
      Production-grade parser.
      Just-in-time compiler (JIT).
      Modular C++ API from the ground up.
      Separate parser and execution engine.
      C++ 11 support through clang.

  PR:		215689
  Submitted by:	Mahdi Mokhtari
  Reviewed by:	mat, novel
  Differential Revision:	https://reviews.freebsd.org/D9012

Changes:
  head/lang/Makefile
  head/lang/cling/
  head/lang/cling/Makefile
  head/lang/cling/distinfo
  head/lang/cling/files/
  head/lang/cling/files/llvm-wrapper.sh.in
  head/lang/cling/files/patch-projects_CMakeLists.txt
  head/lang/cling/files/patch-tools_cling_lib_Interpreter_CIFactory.cpp
  head/lang/cling/files/patch-tools_cling_tools_driver_cling.cpp
  head/lang/cling/pkg-descr
  head/lang/cling/pkg-plist
Comment 8 Roman Bogorodskiy freebsd_committer 2017-01-03 08:09:36 UTC
Committed, thanks!
Comment 9 Mahdi Mokhtari freebsd_committer freebsd_triage 2017-01-03 08:23:34 UTC
(In reply to Roman Bogorodskiy from comment #8)
Thanks for reviews :D
Good job ;)