Bug 216410 - dns/knot2: UDP traffic issues
Summary: dns/knot2: UDP traffic issues
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
Depends on:
Reported: 2017-01-23 17:48 UTC by Henrik Hudson
Modified: 2017-06-26 17:36 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (freebsd)


Note You need to log in before you can comment on or make changes to this bug.
Description Henrik Hudson 2017-01-23 17:48:00 UTC
I upgraded from 10.3-RELEASE to 11.0-RELEASE-p7 this weekend and my knot1 DNS broke. After some Googling I found:


It looks like it's been fixed for 11.0-STABLE in FreeBSD, but the workaround suggested there doesn't seem to work on 11.0-REL-p7 for knot2. The workaround being adding: --enable-recvmmsg=no  to the configure flags.

It looks like that's in the Makefile, but it didn't work for me.

I did update my local Makefile for dns/knot1 with the same suggested workaround and knot1 now works, so I rolled back to knot1 .
Comment 1 Leo Vandewoestijne 2017-01-24 15:03:20 UTC
Thanks for the feedback, I experienced the same in 11 (and have no solution yet).
But with your additional info I can at least improve knot1.
Comment 2 OlivierW 2017-02-21 22:23:09 UTC

The problem has been fixed a while ago: https://svnweb.freebsd.org/ports/head/dns/knot2/Makefile?r1=427187&r2=427186&pathrev=427187
It does work correctly with FreeBSD 11.

PS: I'm the one who had opened the issue on Knot's bugtracker.

Best Regards,
Comment 3 Henrik Hudson 2017-02-22 02:52:25 UTC
Yes, but that doesn't work for me.

dns/knot1 actually does work when I add the --enable-recvmmsg=no manually to the Makefile.

dns/knot2 doesn't work with that fix for me. I have 2.3.3 built using poudriere with IDN enabled and nothing else.

If I install it, convert my config file I get nothing when doing UDP queries. TCP sort of works.

dns/knot1 doesn't work at all for TCP and UDP without --enable-recvmmsg=no on the config.

I tried disabling my PF completely and still no dice. It shows as running on the required port and IP. The one thing weird is that I have it running on a non-primary IP and then unbound is forwarding local zone lookups to it. However, I can't query it directly either. So, don't know if that non-main IP would cause anything.
Comment 4 OlivierW 2017-02-22 11:09:46 UTC

That's very weird.
Like you, I'm compiling Knot 2.3.3 with poudriere and I only enabled IDN. But I'm using it in a simple configuration, as a slave DNS server on standard port 53, with IPv4 and IPv6 connectivity.

When a previous version of Knot2 wasn't working for me on FreeBSD 11, only UDP wasn't working at all. TCP was working fine.
What do you mean by "TCP sort of works"?

I'm wondering if your problem isn't related to something else. Maybe you should ask on FreeBSD forums, giving details of your configuration.

Best Regards,
Comment 5 Leo Vandewoestijne 2017-06-25 22:04:44 UTC
Hello Henrik,

knot2 being many releases further on now, is this still an issue?
(if not then please close this PR).

Comment 6 Henrik Hudson 2017-06-26 17:36:09 UTC
It wasn't a few months ago when I last tried, but it will be fixed via the patch in FreeBSD 11.1 anyway which is now in beta, so I wouldn't expend anymore time on it.