Bug 217178 - www/uwsgi: dies on reload
Summary: www/uwsgi: dies on reload
Status: Closed DUPLICATE of bug 216924
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-17 16:28 UTC by Dmitry Marakasov
Modified: 2017-12-13 13:33 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov freebsd_committer 2017-02-17 16:28:40 UTC
Because of socket ownership changes, on reload uwsgi is no longer possible to chown its socket, and dies on `service uwsgi reload'

In log:

chown(): Operation not permitted [core/utils.c line 2623]

In source:

if (chown(filename, new_uid, new_gid)) {
    uwsgi_error("chown()");
    exit(1);
}

Probably an upstream problem, I've filed bug there as well:

https://github.com/unbit/uwsgi/issues/1471
Comment 1 VK freebsd_triage 2017-12-13 13:33:14 UTC
Close as duplicate of bug #216924 filed earlier and with more info.

*** This bug has been marked as a duplicate of bug 216924 ***