Bug 217199 - multimedia/ffmpeg: build error
Summary: multimedia/ffmpeg: build error
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-multimedia (Nobody)
URL:
Keywords:
Depends on: 215401
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-18 13:41 UTC by hardy.schumacher
Modified: 2017-12-10 18:38 UTC (History)
3 users (show)

See Also:
riggs: maintainer-feedback+


Attachments
Console output from building x11-wm/enlightenment with ffmpeg build error (73.65 KB, application/x-zip-compressed)
2017-02-18 13:41 UTC, hardy.schumacher
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description hardy.schumacher 2017-02-18 13:41:27 UTC
Created attachment 180106 [details]
Console output from building x11-wm/enlightenment with ffmpeg build error

When building port multimedia/ffmpeg on a fresh system, it breaks with an error.
See attached console output for details.

Problem was reproduceable.

OS: FreeBSD-11.0-p7, AMD64
After upgrade to FreeBSD-11, I removed all previous ports and installed following ports from scratch (all with default settings, only on enlightenment I enabled the nvidia patch):
* shells/zsh
* ports-mgmt/portupgrade
* x11/xorg
* x11/nvidia-driver-340
* x11-wm/enlightenment

During build of x11-wm/enlightenment the error occurs.
Comment 1 Trond.Endrestol 2017-04-01 17:20:20 UTC
I had the same problem today. I had to remove the ports' configuration and accept the defaults, i.e. make -C /usr/ports/multimedia/ffmpeg rmconfig && make -C /usr/ports/multimedia/ffmpeg config (hit enter). I finally got it built.
Comment 2 Thomas Zander freebsd_committer 2017-05-14 10:32:54 UTC
Is this still a problem?
Comment 3 Thomas Zander freebsd_committer 2017-12-10 18:38:43 UTC
Please feel free reopen if this turns out to be a problem still.