Bug 217537 - [MAINTAINER] dns/nsd: Update to 4.1.15
Summary: [MAINTAINER] dns/nsd: Update to 4.1.15
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Jason Unovitch
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-04 15:59 UTC by Jaap Akkerhuis
Modified: 2017-03-17 02:20 UTC (History)
2 users (show)

See Also:


Attachments
Patch to update (826 bytes, patch)
2017-03-04 15:59 UTC, Jaap Akkerhuis
jaap: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jaap Akkerhuis 2017-03-04 15:59:32 UTC
Created attachment 180497 [details]
Patch to update

This release contains bugfixes, in serial number parsing and nsec3 hash
collision reporting.

4.1.15
================
BUG FIXES:
- Fix nsd-control and ipv6 only.
- Squelch zone transfer error address family not supported by protocol at low verbosity levels.
- Fix #1195: Fix so that NSD fails on non-compliant values for Serial.
- Fix to rename _t typedefs because POSIX reserves them.
- Fix that nsec3 hash collisions only reported on verbosity level 3.
Comment 1 commit-hook freebsd_committer 2017-03-05 01:03:53 UTC
A commit references this bug:

Author: junovitch
Date: Sun Mar  5 01:03:41 UTC 2017
New revision: 435436
URL: https://svnweb.freebsd.org/changeset/ports/435436

Log:
  dns/nsd: update 4.1.14 -> 4.1.15

  PR:		217537
  Submitted by:	jaap@NLnetLabs.nl (maintainer)

Changes:
  head/dns/nsd/Makefile
  head/dns/nsd/distinfo
Comment 2 Jason Unovitch freebsd_committer 2017-03-05 01:15:01 UTC
Committed. Thanks!
Comment 3 Anton Yuzhaninov 2017-03-10 16:14:59 UTC
There is a build error on FreeBSD 11 / amd64:

cc -I/usr/local/include -I. -O2 -pipe -march=sandybridge  -fstack-protector -fno-strict-aliasing -c ./options.c
cc -I/usr/local/include -I. -O2 -pipe -march=sandybridge  -fstack-protector -fno-strict-aliasing -c ./packet.c
cc -I/usr/local/include -I. -O2 -pipe -march=sandybridge  -fstack-protector -fno-strict-aliasing -c ./query.c
./query.c:667:50: error: use of undeclared identifier 'rbnode_t'
                        memcpy(&temp->node, &additional->node, sizeof(rbnode_t));
                                                                      ^
./query.c:1116:54: error: use of undeclared identifier 'rbnode_t'
                memcpy(&match->node, &wildcard_child->node, sizeof(rbnode_t));
                                                                   ^
2 errors generated.
*** Error code 1
Comment 4 Anton Yuzhaninov 2017-03-10 16:19:56 UTC
Please add this patch to the port:

svn diff -c r4741 https://www.nlnetlabs.nl/svn/nsd/trunk/query.c
Comment 5 Jaap Akkerhuis 2017-03-11 10:54:04 UTC
(In reply to Anton Yuzhaninov from comment #4)
Overtaken by events, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=217640 for details

*** This bug has been marked as a duplicate of bug 217640 ***
Comment 6 Jason Unovitch freebsd_committer 2017-03-17 02:19:09 UTC
(In reply to Anton Yuzhaninov from comment #4)
Thank you for this Anton. Update committed in https://svnweb.FreeBSD.org/changeset/ports/436315 as part of bug 217640. Sorry I didn't note you for crediting the source. I had looked at the parties involved in that bug for the commit message of those involved. Thanks for pointing this out.
Comment 7 Jason Unovitch freebsd_committer 2017-03-17 02:20:17 UTC
Note as "fixed" rather than duplicate to be most correct. This PR was for updating for 4.1.14 -> 4.1.15 and not fixing the RADIXTREE option.