Bug 217761 - FreeBSD/powerpc64 head r313561's /boot/loader cannot boot the kernel from NFS
Summary: FreeBSD/powerpc64 head r313561's /boot/loader cannot boot the kernel from NFS
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: powerpc Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-13 16:35 UTC by Hiroo Ono
Modified: 2017-03-23 23:27 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hiroo Ono 2017-03-13 16:35:12 UTC
I installed FreeBSD/powerpc64 head r313561 (snapshot of 20170210) and there is something wrong with its bootloader.

I tried to net boot the installer. The configuration of isc-dhcp is:

host powerpc {
  hardware ethernet xxx:xx:xx:xx:xx:xx;
  fixed address 192.168.0.15;
  next-server 192.168.0.10;
  filename "loader";
  option root-path "192.168.0.10:/exports/FreeBSD/ppc64/12c-20170210";
}

tftp configuration in inetd.conf is:

tftp dgram udp wait root /usr/local/libexec/in.tftpd in.tftpd -s /exports/FreeBSD/ppc64/12c-20170210/boot

and 192.168.0.10:/exports/FreeBSD/ppc64/12c-20170210 is NFS mountable with full system
copied from disc1.iso.

I tried to boot from openfirmware console

> boot eboot:,loader

the file loader is retrieved via tftp and executed, but it says it cannot find the file 'kernel'.

I replaced /boot/loader with the loader of 11.0-RELEASE. It successfully booted /boot/kernel/kernel,
and I managed to install.