Bug 218294 - net/shadowsocks-libev new version to 3.1.0
Summary: net/shadowsocks-libev new version to 3.1.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Guangyuan Yang
URL: https://reviews.freebsd.org/D13099
Keywords:
Depends on: 223095
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-01 18:38 UTC by xsan
Modified: 2017-11-17 01:10 UTC (History)
8 users (show)

See Also:
xiaoding+freebsd: maintainer-feedback+


Attachments
shar file for ports. (3.54 KB, text/plain)
2017-04-01 18:40 UTC, xsan
no flags Details
Diff patch. (5.17 KB, patch)
2017-07-27 06:21 UTC, xsan
no flags Details | Diff
diff to upgrade to 3.0.7 based on 2.4.7 (3.22 KB, patch)
2017-10-02 10:20 UTC, Sutra
no flags Details | Diff
diff to upgrade to 3.1.0 based on 2.4.7 (3.22 KB, patch)
2017-10-02 15:19 UTC, Sutra
no flags Details | Diff
diff to upgrade to 3.1.0 based on 2.4.7 (3.23 KB, patch)
2017-10-16 04:43 UTC, Sutra
no flags Details | Diff
diff to upgrade to 3.1.0 based on 2.4.7 (3.71 KB, patch)
2017-10-24 13:47 UTC, Sutra
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description xsan 2017-04-01 18:38:50 UTC
The shadowsocks-libev in ports version is too old, it was public for many years.
Now the shadowsocks-libev has more function and improvement, this is the whole new version of shadowsocks-libev for ports.
Comment 1 xsan 2017-04-01 18:40:53 UTC
Created attachment 181389 [details]
shar file for ports.
Comment 2 xiaoding+freebsd 2017-04-04 14:24:17 UTC
Accepted.
Thanks!
Comment 3 xsan 2017-04-05 11:08:54 UTC
Thanks!
Comment 4 Martin Wilke freebsd_committer 2017-05-05 03:39:07 UTC
Hey,

Please submit a diff instance of a shar.

Thanks
Comment 5 xsan 2017-07-27 06:21:11 UTC
Created attachment 184755 [details]
Diff patch.

This is the diff patch file of this ports.
Comment 6 Sutra 2017-10-02 10:20:58 UTC
Created attachment 186858 [details]
diff to upgrade to 3.0.7 based on 2.4.7
Comment 7 Sutra 2017-10-02 15:19:01 UTC
Created attachment 186865 [details]
diff to upgrade to 3.1.0 based on 2.4.7
Comment 8 xsan 2017-10-15 10:21:17 UTC
Looks like there is no hope to upgrade this port..
Comment 9 Sutra 2017-10-15 10:29:28 UTC
(In reply to xsan from comment #8)
As per porter's handbook, if the maintainer does not respond to an update request after two weeks (excluding major public holidays), then that is considered a maintainer timeout, and the update may be made without explicit maintainer approval.
Comment 10 Guangyuan Yang freebsd_committer 2017-10-16 01:48:16 UTC
(In reply to Sutra from comment #9)

That is correct. I will test the patch and see if I could commit it.
Comment 11 Guangyuan Yang freebsd_committer 2017-10-16 02:40:48 UTC
(In reply to Sutra from comment #7)

`portlint -C` reports: WARN: Makefile: [23]: USE_* seen before USES.  According to the porters-handbook, USES must appear first.

Please update the patch to reflect this, thanks!
Comment 12 Sutra 2017-10-16 04:43:39 UTC
Created attachment 187206 [details]
diff to upgrade to 3.1.0 based on 2.4.7
Comment 13 Guangyuan Yang freebsd_committer 2017-10-16 09:42:19 UTC
(In reply to Sutra from comment #12)

TEST PLAN:

portlint -C: Passed

poudriere testport:

- 11.1-RELEASE amd64: Passed
http://poudriere.charlieyang.me/build.html?mastername=111Ramd64-development&build=2017-10-16_09h22m38s

- 10.4-RELEASE i386: Passed
http://poudriere.charlieyang.me/build.html?mastername=104Ri386-development&build=2017-10-16_09h32m46s
Comment 14 Adam Weinberger freebsd_committer 2017-10-19 03:13:06 UTC
There are some issues that need to be ironed out first, please.

${CP} shouldn't be used to put files into ${STAGEDIR}; it should be ${INSTALL_DATA} instead.

%%PORTDOCS%% is meaningless without a DOCS option (%%PORTDOCS%% expands based upon whether the DOCS option is enabled, but there's no options at all for this port).

asciidoc should almost never be a mandatory dependency, and it's huge enough that it should never be behind the DOCS option either.

Consider something like this instead:

Makefile:
OPTIONS_DEFINE=  HTMLDOCS
OPTIONS_DEFAULT= HTMLDOCS
OPTIONS_SUB=     yes

HTMLDOCS_BUILD_DEPENDS=    asciidoc:... xmlto:...
HTMLDOCS_CONFIGURE_ENABLE=    docs
(That equates to --enable-docs or --disable-docs, change it to be what the actual configure knob is)

pkg-plist:
%%HTMLDOCS%%%%DOCSDIR%%/foo/bar.html
Comment 15 Guangyuan Yang freebsd_committer 2017-10-23 13:19:47 UTC
Thanks Adam. @Sutra, do you still want to work on this patch?

Also FYI, the maintainer is willing to give up the maintainership for anyone interested (in PR223095).
Comment 16 Sutra 2017-10-24 13:47:29 UTC
Created attachment 187427 [details]
diff to upgrade to 3.1.0 based on 2.4.7
Comment 17 xiaoding+freebsd 2017-10-25 07:52:41 UTC
(In reply to Sutra from comment #16)
Accepted with thanks!
@Sutra, you can take the port maintainership if you will. I am afraid I may not have enough time in maintaining.
Comment 18 xiaoding+freebsd 2017-10-25 08:02:43 UTC
(In reply to Sutra from comment #16)
Here are some functional improvements we can make effort:

* Add UDP flag. The new version comes with "-u" flag to support udp relay mode. We can add support in shadowsocks-libev rc script.

* Support client mode. This port was intended to be a server side service providing access to remote clients. However, some desktop users also need the client side functionality. We can add "shadowsocks_libev_client_enable" variable to rc script to support.

* Support multiple instances. Different instances with different ports/encryption methods is also very useful to some users.

Thanks!
Comment 19 Sutra 2017-11-04 15:34:02 UTC
(In reply to xiaoding+freebsd from comment #18)
> * Add UDP flag. The new version comes with "-u" flag to support udp relay mode. We can add support in shadowsocks-libev rc script.
The "-u" flag could be specified by the json format config file, using "mode": "tcp_and_udp".
Comment 20 commit-hook freebsd_committer 2017-11-16 17:36:39 UTC
A commit references this bug:

Author: ygy
Date: Thu Nov 16 17:35:37 UTC 2017
New revision: 454320
URL: https://svnweb.freebsd.org/changeset/ports/454320

Log:
  net/shadowsocks-libev: Update to 3.1.0

  PR:		218294
  Submitted by:	Anonymous
  Approved by:	xiaoding+freebsd@xiaoding.org (maintainer), adamw
  Differential Revision:	https://reviews.freebsd.org/D13099

Changes:
  head/net/shadowsocks-libev/Makefile
  head/net/shadowsocks-libev/distinfo
  head/net/shadowsocks-libev/pkg-plist