Bug 218404 - x11-toolkits/qt5-widgets complains about duplicate symbols in libQt5Core.so
Summary: x11-toolkits/qt5-widgets complains about duplicate symbols in libQt5Core.so
Status: Closed DUPLICATE of bug 218187
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-05 20:05 UTC by Trond.Endrestol
Modified: 2017-04-05 20:14 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments
Complete build log (31.86 KB, text/plain)
2017-04-05 20:05 UTC, Trond.Endrestol
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Trond.Endrestol 2017-04-05 20:05:05 UTC
Created attachment 181516 [details]
Complete build log

Complete build log is attached.
To summarize:

System is stable/11 amd64 at r316491, thus the system compiler is FreeBSD's clang 4.0.0. Ports tree is at r437806.

x11-toolkits/qt5-widgets complains about duplicate symbols in libQt5Core.so:

/usr/ports/workdirs/usr/ports/x11-toolkits/qt5-widgets/work/qtbase-opensource-src-5.7.1/lib/libQt5Core.so:(.dynamic+0x27ad8): multiple definition of `__bss_start@Qt_5'
/usr/ports/workdirs/usr/ports/x11-toolkits/qt5-widgets/work/qtbase-opensource-src-5.7.1/lib/libQt5Core.so:(.dynamic+0x27ad8): first defined here
/usr/ports/workdirs/usr/ports/x11-toolkits/qt5-widgets/work/qtbase-opensource-src-5.7.1/lib/libQt5Core.so:(.dynamic+0x27ad8): multiple definition of `_edata@Qt_5'
/usr/ports/workdirs/usr/ports/x11-toolkits/qt5-widgets/work/qtbase-opensource-src-5.7.1/lib/libQt5Core.so:(.dynamic+0x27ad8): first defined here
/usr/ports/workdirs/usr/ports/x11-toolkits/qt5-widgets/work/qtbase-opensource-src-5.7.1/lib/libQt5Core.so:(.dynamic+0x2b2d0): multiple definition of `_end@Qt_5'

Note, the linker is referring to a library from within the work directory, not the library installed in /usr/local/lib/qt5 by devel/qt5-core. Maybe that's the real problem.
Comment 1 Trond.Endrestol 2017-04-05 20:12:11 UTC
(In reply to Trond.Endrestol from comment #0)
I forcefully rebuilt devel/qt5-core using portupgrade:

portupgrade -fprv devel/qt5-core

It didn't help. x11-toolkits/qt5-widgets still complains about duplicate symbols.
Comment 2 Tobias C. Berner freebsd_committer 2017-04-05 20:14:48 UTC
(In reply to Trond.Endrestol from comment #0)
The library in the wrkdirectory is a symlink to the installed one :)

*** This bug has been marked as a duplicate of bug 218187 ***