Bug 218775 - [PATCH] devel/llvm40 build botched up after shebangfix changes
Summary: [PATCH] devel/llvm40 build botched up after shebangfix changes
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Brooks Davis
URL:
Keywords: patch
: 218774 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-20 10:04 UTC by Helge Oldach
Modified: 2017-04-21 15:06 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (brooks)


Attachments
patch (1.09 KB, patch)
2017-04-20 10:05 UTC, Helge Oldach
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Helge Oldach 2017-04-20 10:04:12 UTC
llvm40 does not build without the EXTRAS option enabled:

==>  License LLVM accepted by the user
===>   llvm40-4.0.0_4 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by llvm40-4.0.0_4 for building
===>  Extracting for llvm40-4.0.0_4
=> SHA256 Checksum OK for llvm-4.0.0.src.tar.xz.
=> SHA256 Checksum OK for cfe-4.0.0.src.tar.xz.
/bin/mv /usr/obj/usr/ports/devel/llvm40/work/cfe-4.0.0.src /usr/obj/usr/ports/devel/llvm40/work/llvm-4.0.0.src/tools/clang
===>  Patching for llvm40-4.0.0_4
sed: tools/clang/tools/extra/clang-tidy/tool/clang-tidy-diff.py: No such file or directory
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/llvm40
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/llvm40

Close-to-trivial fix attached.
Comment 1 Helge Oldach 2017-04-20 10:05:01 UTC
Created attachment 181935 [details]
patch
Comment 2 Helge Oldach 2017-04-21 10:48:51 UTC
*** Bug 218774 has been marked as a duplicate of this bug. ***
Comment 3 commit-hook freebsd_committer 2017-04-21 15:03:49 UTC
A commit references this bug:

Author: brooks
Date: Fri Apr 21 15:03:21 UTC 2017
New revision: 439084
URL: https://svnweb.freebsd.org/changeset/ports/439084

Log:
  Fix SHEBANG_FILES when the EXTRAS option is disabled.

  PR:		218719, 218775, 218776
  Submitted by:	Helge Oldach <freebsd@oldach.net>, owen@easytarget.org

Changes:
  head/devel/llvm38/Makefile
  head/devel/llvm39/Makefile
  head/devel/llvm40/Makefile