Bug 218862 - games/aisleriot: update 3.18.2 -> 3.22.2
Summary: games/aisleriot: update 3.18.2 -> 3.22.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
: 216505 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-25 00:23 UTC by rkoberman
Modified: 2017-05-12 02:48 UTC (History)
5 users (show)

See Also:
pi: maintainer-feedback-


Attachments
svn-diff-games_aisleriot (3.42 KB, patch)
2017-04-25 16:43 UTC, Walter Schwarzenfeld
no flags Details | Diff
svn-diff-games_aisleriot (3.49 KB, patch)
2017-05-10 06:01 UTC, Walter Schwarzenfeld
no flags Details | Diff
svn-diff-games_aisleriot_3_22_2 (4.07 KB, patch)
2017-05-11 20:36 UTC, Walter Schwarzenfeld
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rkoberman 2017-04-25 00:23:52 UTC
Updates to gtk3 and related ports broke games/aisleriot. Specifically, sol segfaults on startup.
(gdb) bt
#0  0x000000002d5850e8 in ?? ()
#1  0x00007fffffffd060 in ?? ()
#2  0x0000000000413302 in style_updated_cb (widget=0x0, style=0x0)
    at ar-style-gtk.c:295
Previous frame identical to this frame (corrupt stack?)

Reverting 439206 allows it to run again. I suspect an update of aisleriot to a reasonably recent release will fix the problem.
Comment 1 Carlos J. Puga Medina freebsd_committer 2017-04-25 01:22:17 UTC
(In reply to rkoberman from comment #0)

Yes, I confirm that updating aisleriot to 3.20.1 fixes the problem.

Changes: https://download.gnome.org/sources/aisleriot/3.20/aisleriot-3.20.1.changes
Comment 2 Walter Schwarzenfeld freebsd_triage 2017-04-25 02:25:07 UTC
https://git.gnome.org//browse/aisleriot/ :
=> 2017-03-19	build: Build against guile 2.2 by default

(I tried the update just for me to 3.22.1 with guile-2.0.14. It
seems to work). But i don't know if it is needed to update guile.
Comment 3 rkoberman 2017-04-25 07:17:34 UTC
There is an open ticket to update games/aisleriot to 3.22.1, and is assigned to gnome@. https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=216505. While it was opened, nothing appears to have been done with it. No patch to the Makefile, just a statement that the port is a bit out of date. It builds and runs on amd64 with only changing the version in the Makefile. 

Only tested on 11-STABLE (r317350).
Comment 4 Walter Schwarzenfeld freebsd_triage 2017-04-25 10:54:35 UTC
I had an update patch. Shoud I attach it, or should I wait for the guile
update and CC the maintainer of guile (or open update request for it)?
Comment 5 Walter Schwarzenfeld freebsd_triage 2017-04-25 12:23:07 UTC
Opened an update request for guile2 Bug 218874.
Comment 6 Carlos J. Puga Medina freebsd_committer 2017-04-25 16:31:15 UTC
(In reply to w.schwarzenfeld from comment #5)

aisleriot can build against guile 2.0 or 2.2 (by default).

https://github.com/GNOME/aisleriot/blob/master/configure.ac#L479
Comment 7 Walter Schwarzenfeld freebsd_triage 2017-04-25 16:43:48 UTC
Created attachment 182083 [details]
svn-diff-games_aisleriot

I was not clear about boehm-gc-thread. I don't think
it is really needed. So I  commented out.

portlint ok.
Testbuilds with poudriere on 10.3-amd64/i386 ok.

ChangeLog:
s://git.gnome.org//browse/aisleriot/
Comment 8 Walter Schwarzenfeld freebsd_triage 2017-04-25 16:45:27 UTC
Paiste error:
https://git.gnome.org//browse/aisleriot/
Comment 9 rkoberman 2017-05-10 04:58:51 UTC
This works correctly as is. My only question is whether boehm-gc-threaded is a dependency. The executable, sol, is linked to libgc-threaded which is provided by devel/boehm-gc-threaded, but looks like it is added by the staging process. Still, if the port is not installed, rtld will bail with a missing library.

At least on my system devel/boehm-gc-threaded is depended on only by devel/boehm-gc and is linked in by stage-qa. (boehm-gc shows nothing depending on it, so it may not even belong here, but I don't believe that.)

Any explanation would certainly be appreciated!
Comment 10 Walter Schwarzenfeld freebsd_triage 2017-05-10 06:01:36 UTC
Created attachment 182464 [details]
svn-diff-games_aisleriot
Comment 11 Walter Schwarzenfeld freebsd_triage 2017-05-10 06:03:04 UTC
Forget to remove old portversion.
Uncommented boehm-gc-threaded lib-depends.
Comment 12 Kurt Jaeger freebsd_committer 2017-05-11 17:35:58 UTC
*** Bug 216505 has been marked as a duplicate of this bug. ***
Comment 13 Walter Schwarzenfeld freebsd_triage 2017-05-11 20:36:23 UTC
Created attachment 182519 [details]
svn-diff-games_aisleriot_3_22_2

In the meantime a newer version 3.22.2 (from 7.5. 2017).
Comment 14 Koop Mast freebsd_committer 2017-05-11 21:07:12 UTC
Hi, thanks for the report. I'm almost done "playing" in webkit land. After that I will tackle updating the games/utils!
Comment 16 Kurt Jaeger freebsd_committer 2017-05-12 02:48:05 UTC
Committed, thanks!