Bug 218909 - multimedia/mpv: update to 0.25.0 fails
Summary: multimedia/mpv: update to 0.25.0 fails
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Carlos J. Puga Medina
URL:
Keywords: patch, patch-ready
: 218920 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-27 09:17 UTC by rozhuk.im
Modified: 2017-04-27 19:44 UTC (History)
3 users (show)

See Also:
cpm: maintainer-feedback+


Attachments
patch (1.29 KB, patch)
2017-04-27 17:47 UTC, Carlos J. Puga Medina
cpm: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rozhuk.im 2017-04-27 09:17:29 UTC
...
===>   mpv-0.25.0,1 depends on shared library: libpango-1.0.so - found (/usr/local/lib/libpango-1.0.so)
===>   mpv-0.25.0,1 depends on shared library: libgbm.so - found (/usr/local/lib/libgbm.so)
===>  Configuring for mpv-0.25.0,1
waf [commands] [options]

Main commands (example: ./waf build -j4)
  build    : executes the build
  clean    : cleans the project
  conf     : 
	Decorator: attach new configuration functions to :py:class:`waflib.Build.BuildContext` and
	:py:class:`waflib.Configure.ConfigurationContext`. The methods bound will accept a parameter
	named 'mandatory' to disable the configuration errors::

		def configure(conf):
			conf.find_program('abc', mandatory=False)

	:param f: method to bind
	:type f: function
	
  configure: configures the project
  dist     : makes a tarball for redistributing the sources
...
Comment 1 Carlos J. Puga Medina freebsd_committer 2017-04-27 10:13:18 UTC
It seems that /usr/ports/Mk/Uses/waf.mk is missing.

Can you check it please?
Comment 2 rozhuk.im 2017-04-27 11:47:09 UTC
(In reply to Carlos J. Puga Medina from comment #1)

cat /usr/ports/Mk/Uses/waf.mk
# $FreeBSD: head/Mk/Uses/waf.mk 423928 2016-10-13 16:26:09Z amdmi3 $
#
# Provide support to use the waf building system
#
# Feature:		waf
# Usage:		USES=waf
#
# It implies USES=python:build automatically is no USES=python has been
# specified yet
#
# WAF_CMD		can be specified in the ports if the waf script is not
# 			in WRKSRC/waf
# CONFIGURE_TARGET	default to 'configure'
# ALL_TARGET		default to 'build'
# INSTALL_TARGET=	default to 'install'

.if !defined(_INCLUDE_USES_WAF_MK)
_INCLUDE_USES_WAF_MK=	yes

.if !empty(waf_ARGS)
IGNORE=	Incorrect 'USES+= waf:${waf_ARGS}' waf takes no arguments
.endif

.if !${USES:Mpython*}
python_ARGS=	2,build
.include "${USESDIR}/python.mk"
.endif

MAKEFILE=	#
MAKE_FLAGS=	#
ALL_TARGET=	#
HAS_CONFIGURE=	yes
MAKE_ARGS+=	--verbose
WAF_CMD?=	./waf

CONFIGURE_TARGET?=	configure
ALL_TARGET?=		build
INSTALL_TARGET?=	install

CONFIGURE_CMD=	${PYTHON_CMD} ${WAF_CMD} ${CONFIGURE_TARGET}
MAKE_CMD=	${PYTHON_CMD} ${WAF_CMD}
CONFIGURE_ARGS+=	--prefix=${PREFIX} \
			${_MAKE_JOBS}

DESTDIRNAME=	--destdir

# Set a minimal job of 1
_MAKE_JOBS=	-j${MAKE_JOBS_NUMBER}

.endif
Comment 3 Carlos J. Puga Medina freebsd_committer 2017-04-27 12:06:34 UTC
Please, provide more information:

- uname -a output
- content of your /etc/make.conf
- full build log
Comment 4 Carlos J. Puga Medina freebsd_committer 2017-04-27 12:43:02 UTC
Also, show the output of 'make showconfig'
Comment 5 bkazemi 2017-04-27 17:04:57 UTC
Same issue, I think the problematic line was omitted:

waf-light: error: no such option: --disable-xinerama
===>  Script "configure" failed unexpectedly.

and then it fails.
Comment 6 bkazemi 2017-04-27 17:13:05 UTC
(In reply to bkazemi from comment #5)
Confirmed xinerama issue for me, commenting out the XINERAMA_* lines in the Makefile allows me to build.
Comment 7 Carlos J. Puga Medina freebsd_committer 2017-04-27 17:47:39 UTC
Created attachment 182132 [details]
patch
Comment 8 Carlos J. Puga Medina freebsd_committer 2017-04-27 18:22:43 UTC
mpv 0.25.0 makes xinerama dependency mandatory.

https://github.com/mpv-player/mpv/commit/927afa311d4a89b022305508acbf4e7325fe3928
Comment 9 Carlos J. Puga Medina freebsd_committer 2017-04-27 19:16:44 UTC
*** Bug 218920 has been marked as a duplicate of this bug. ***
Comment 10 commit-hook freebsd_committer 2017-04-27 19:43:48 UTC
A commit references this bug:

Author: cpm
Date: Thu Apr 27 19:42:50 UTC 2017
New revision: 439562
URL: https://svnweb.freebsd.org/changeset/ports/439562

Log:
  - Remove XINERAMA option since mpv makes xinerama dependency mandatory.

  waf-light: error: no such option: --disable-xinerama
  ===>  Script "configure" failed unexpectedly.

  PR:		218909
  Reported by:	rozhuk.im@gmail.com

Changes:
  head/multimedia/mpv/Makefile
Comment 11 Carlos J. Puga Medina freebsd_committer 2017-04-27 19:44:54 UTC
Committed!

Thanks for reporting