Bug 219471 - <PMake — A Tutorial>: mention -p2 flag but do not exist for make
Summary: <PMake — A Tutorial>: mention -p2 flag but do not exist for make
Status: Closed Works As Intended
Alias: None
Product: Documentation
Classification: Unclassified
Component: Documentation (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-doc mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-23 09:36 UTC by Jov
Modified: 2017-05-26 09:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jov 2017-05-23 09:36:15 UTC
in chapter 2.6 : 
In answering this, two flags will serve you well: -d m and “-p 2”...

but
make -p 2
usage: make [-BeikNnqrstWwX] 
            [-C directory] [-D variable] [-d flags] [-f makefile]
            [-I directory] [-J private] [-j max_jobs] [-m directory] [-T file]
            [-V variable] [variable=value] [target ...]

This is FreeBSD 10.3R
Comment 1 Baptiste Daroussin freebsd_committer 2017-05-25 20:47:13 UTC
This documentation is there for history and actually was removed. FreeBSD does not use pmake anymore but bmake.
Comment 2 Jov 2017-05-26 09:26:45 UTC
But the man page of make and /usr/share/mk/bsd.README still reference this doc:

man of page:
This manual page is intended as a reference document only.  For a more
     thorough description of make and makefiles, please refer to PMake - A
     Tutorial.

/usr/share/mk/bsd.README:
See also make(1), mkdep(1), style.Makefile(5) and `PMake - A Tutorial', located in /usr/share/doc/psd/12.make.

I will open a PR for this.