Bug 220309 - usr.bin.grep.grep_test:mmap_eof_not_eol failing after jemalloc upgrade
Summary: usr.bin.grep.grep_test:mmap_eof_not_eol failing after jemalloc upgrade
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: tests (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Many People
Assignee: Kyle Evans
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-27 17:16 UTC by Enji Cooper
Modified: 2018-01-29 18:51 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Enji Cooper freebsd_committer 2017-06-27 17:16:09 UTC
From https://ci.freebsd.org/job/FreeBSD-head-amd64-test/3297/testReport/usr.bin.grep/grep_test/mmap_eof_not_eol/ :

Fail: program did not exit cleanly
stdout:

stderr:
<jemalloc>: Invalid conf pair: redzone:true
<jemalloc>: Abort (abort_conf:true) on invalid conf value (see above).

Files left in work directory after failure: grep.core, test1, test2
Comment 1 commit-hook freebsd_committer 2017-06-27 17:22:10 UTC
A commit references this bug:

Author: ngie
Date: Tue Jun 27 17:22:04 UTC 2017
New revision: 320414
URL: https://svnweb.freebsd.org/changeset/base/320414

Log:
  Expect :mmap_eof_not_eol to fail

  It relies on a jemalloc feature (opt.redzone) no longer available after
  r319971.

  MFC with:	r318908, r319971
  PR:		220309

Changes:
  head/contrib/netbsd-tests/usr.bin/grep/t_grep.sh
Comment 2 Enji Cooper freebsd_committer 2017-11-05 20:05:20 UTC
This should be Kyle's bug.
Comment 3 Kyle Evans freebsd_committer 2017-11-06 02:39:32 UTC
(In reply to Ngie Cooper from comment #2)

Apologies- this completely fell off of my radar. I'm considering ripping this test out. I haven't been able to conceive of a way to test this regression without the redzone support, since it relies on a subtle overflow.
Comment 4 commit-hook freebsd_committer 2018-01-29 18:51:07 UTC
A commit references this bug:

Author: kevans
Date: Mon Jan 29 18:50:46 UTC 2018
New revision: 328559
URL: https://svnweb.freebsd.org/changeset/base/328559

Log:
  Remove t_grep:mmap_eof_not_eol test

  The test was marked as an expected failure in r320414 after r319971's import
  of a newer jemalloc removed an essential feature (opt.redzone) for
  reproducing the behavior it was testing. Since then, no way has been found
  or demonstrated to reliably test the behavior, so remove the test.

  PR:		220309

Changes:
  head/contrib/netbsd-tests/usr.bin/grep/t_grep.sh