Bug 220446 - sysutils/syslog-ng310: Fails to package with CURL option disabled
Summary: sysutils/syslog-ng310: Fails to package with CURL option disabled
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Cy Schubert
URL: https://reviews.freebsd.org/D11456
Keywords: needs-qa, regression
Depends on:
Blocks:
 
Reported: 2017-07-03 08:17 UTC by Dani
Modified: 2017-07-03 23:28 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (cy)
i.dani: merge-quarterly?


Attachments
Fix pkg-plist, libhttp.so is only available when building with CURL=ON (Default: OFF) (1.06 KB, patch)
2017-07-03 08:17 UTC, Dani
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dani 2017-07-03 08:17:31 UTC
Created attachment 184031 [details]
Fix pkg-plist, libhttp.so is only available when building with CURL=ON (Default: OFF)

After the update from 3.9.1 to 3.10.1, the build was broken because of a wrong pkg-plist entry. -> Caused by ports rP444616

Removed:
Makefile: CURL_PLIST_FILES= lib/syslog-ng/libcurl.so

Added:
pkg-plist: lib/syslog-ng/libhttp.so

libcurl.so has been renamed to libhttp.so -> See: https://github.com/balabit/syslog-ng/releases/tag/syslog-ng-3.10.1

But libhttp.so is not ALWAYS and DEFAULT available, it's only there if the port is built with CURL=ON (DEFAULT=OFF). So move it back to the Makefile and remove the static entry from pkg-plist.

Fixed in review D11456

Error:
===========================================================================
=======================<phase: package        >============================
===>  Building package for syslog-ng310-3.10.1
pkg-static: Unable to access file /wrkdirs/usr/ports/sysutils/syslog-ng310/work/stage/usr/local/lib/syslog-ng/libhttp.so:No such file or directory
*** Error code 1
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2017-07-03 08:53:35 UTC
Thank you Dani. If the quarterly version is also affected please set the merge-quarterly flag to ?
Comment 2 commit-hook freebsd_committer 2017-07-03 18:34:51 UTC
A commit references this bug:

Author: cy
Date: Mon Jul  3 18:33:49 UTC 2017
New revision: 444977
URL: https://svnweb.freebsd.org/changeset/ports/444977

Log:
  Fix broken plist.

  PR:		220446
  Submitted by:	i.dani@outlook.com
  Reviewed by:	cy
  MFH:		2017Q3
  Differential Revision:	D11456

Changes:
  head/sysutils/syslog-ng310/Makefile
  head/sysutils/syslog-ng310/pkg-plist
Comment 3 Cy Schubert freebsd_committer 2017-07-03 18:35:19 UTC
Committed. Thanks.
Comment 4 commit-hook freebsd_committer 2017-07-03 23:28:55 UTC
A commit references this bug:

Author: cy
Date: Mon Jul  3 23:28:12 UTC 2017
New revision: 444993
URL: https://svnweb.freebsd.org/changeset/ports/444993

Log:
  MFH: r444977

  Fix broken plist.

  PR:		220446
  Submitted by:	i.dani@outlook.com
  Reviewed by:	cy
  Differential Revision:	D11456

  Approved by:	portmgr (adamw)

Changes:
_U  branches/2017Q3/
  branches/2017Q3/sysutils/syslog-ng310/Makefile
  branches/2017Q3/sysutils/syslog-ng310/pkg-plist