Bug 220542 - Packages for armv6 are more than 1 month old
Summary: Packages for armv6 are more than 1 month old
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Package Infrastructure (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Only Me
Assignee: Port Management Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-07 14:58 UTC by Sylvain Garrigues
Modified: 2019-09-05 09:48 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvain Garrigues 2017-07-07 14:58:58 UTC
Looking at last modified date here:
http://pkg.freebsd.org/FreeBSD:12:armv6/

I feel like our packages for armv6 no longer build.

If I look at a random port build log, seems like qemu is having trouble:
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p445114_s320698/logs/perl5-5.24.1_1.log

qemu: unsupported syscall: 551 (calling anyway)
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2017-07-08 04:34:56 UTC
The problem is that perl no longer builds, thus, there is no reason to push package sets until this can be fixed.  IIUC the 551/552 problem is related but not the problem.
Comment 2 Sylvain Garrigues 2017-07-08 08:44:50 UTC
Perl does build on CURRENT:
https://dev.sylvaingarrigues.com/freebsd/data/20170706-default/2017-07-06_14h10m10s/logs/perl5-5.24.1_1.log

The problem is related to the specific cross-building machine setup (qemu, poudriere, jail version): see the numerous qemu problems in each port log.

Might be related to the version of qemu-user installed on the building machine, and this bug https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=220478 which is now fixed.
Comment 3 Michal Meloun freebsd_committer 2017-07-09 06:31:36 UTC
The problem is that the qemu-user-static package that runs on CURRENT build machine (beefy8) has been built on FreeBSD 11 system. But, unfortunately, qemu cannot emulate a newer revision of the system which was built on.

In short, if you want qemu-user-static emulation for CURRENT then package must be built also on CURRENT.
Comment 4 Sylvain Garrigues 2017-07-10 08:53:50 UTC
Thanks for your answer. 

QEMU does build and run on CURRENT (I do have my own poudriere setup for CURRENT armv6 running sucessfully), so I guess it takes the beefy8 machine admin to upgrade packages. 

I can provide help and time.
Comment 5 Baptiste Daroussin freebsd_committer 2019-09-05 09:48:12 UTC
Thanks for the offer! the situation is back to normal