Bug 220581 - www/firefox depends on kitchen sink
Summary: www/firefox depends on kitchen sink
Status: Closed DUPLICATE of bug 194460
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gecko mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-09 16:02 UTC by Andy
Modified: 2017-07-09 17:47 UTC (History)
0 users

See Also:
jbeich: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2017-07-09 16:02:55 UTC
More recent firefox build removed toolkit option (April 11, 438318 by jbeich) so there is no way to build it without pulling in the entire linux/freedesktop world.  That is due entirely to gtk3's tightly coupled integration with atk which demands dbus.  So the firefox 'dbus' option is totally irrelevant now since it is always pulled in.  Is gtk3 really that necessary?  If so it should be patched to remove the atk/dbus dependency, or just add gtk2 support back to FF.
Comment 1 Jan Beich freebsd_committer 2017-07-09 16:32:51 UTC
Gtk2 build is broken[1] and unmaintained upstream but Gtk3 has a patch to build without DBus in a separate bug.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1278282#c19

*** This bug has been marked as a duplicate of bug 194460 ***
Comment 2 Andy 2017-07-09 17:47:18 UTC
Such a quick reply, and on a Sunday!  Thanks, I will monitor the gtk3 patch you linked to, that looks very promising (and uplifting).  When I looked at manually removing atk from gtk3 I almost fainted due to tight coupling.