Bug 220733 - [patch] dns/unbound: enable libevent support by default
Summary: [patch] dns/unbound: enable libevent support by default
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Eugene Grosbein
URL:
Keywords: patch
: 220730 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-07-14 14:25 UTC by Dmitry Luhtionov
Modified: 2017-07-23 14:08 UTC (History)
2 users (show)

See Also:
jaap: maintainer-feedback+


Attachments
Patch for Makefile (437 bytes, patch)
2017-07-14 14:25 UTC, Dmitry Luhtionov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Luhtionov 2017-07-14 14:25:17 UTC
Created attachment 184354 [details]
Patch for Makefile

Unbound without libevent already present in base system.

For maximum performance, we always need to enable libevent support.

But, will not be able make this, if we install unbound from package.
Comment 1 Jaap Akkerhuis 2017-07-15 09:29:21 UTC
In general I'm not a fan of adding extra dependencies if it can be avoided. However, for unbound it is in the planning to make libevent default starting 1.7.x.

I've contacted the upstreams to see whether they don't mind doing it now.
Comment 2 Jaap Akkerhuis 2017-07-23 13:26:24 UTC
After contacting the upstreams, I don't see any problem making libevent default. So yes, go ahead.
Comment 3 commit-hook freebsd_committer 2017-07-23 14:04:09 UTC
A commit references this bug:

Author: eugen
Date: Sun Jul 23 14:03:53 UTC 2017
New revision: 446477
URL: https://svnweb.freebsd.org/changeset/ports/446477

Log:
  Base system contains unbound without libevent support enabled.
  Enable libevent by default for the port dns/unbound for performance reasons.

  PR:		220733
  Submitted by:	Dmitry Luhtionov
  Approved by:	jaap (maintainer), az (mentor)

Changes:
  head/dns/unbound/Makefile
Comment 4 Eugene Grosbein freebsd_committer 2017-07-23 14:07:42 UTC
Committed, thanks!
Comment 5 Eugene Grosbein freebsd_committer 2017-07-23 14:08:51 UTC
*** Bug 220730 has been marked as a duplicate of this bug. ***