Bug 220755 - ports-mgmt/pkg wrongly attempts to install compat6x-amd64 when upgrading packages
Summary: ports-mgmt/pkg wrongly attempts to install compat6x-amd64 when upgrading pack...
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Walter Schwarzenfeld
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-16 09:37 UTC by Mike Clarke
Modified: 2019-08-15 06:42 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (pkg)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Clarke 2017-07-16 09:37:58 UTC
curlew:/# uname -a                                                                         
FreeBSD curlew.lan 11.0-RELEASE-p9 FreeBSD 11.0-RELEASE-p9 #0: Tue Apr 11 08:48:40 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64 

curlew:/# pkg query %n-%v pkg
pkg-1.10.1

"pkg upgrade samba44" upgrades samba44 but also installs compat6x-amd64. But using portmaster to upgrade from ports only upgrades samba44

If I allow pkg to install compat6x-amd64 then pkg info shows that it is not required by any package and I am able to delete it without any problem.

########## Example with portmaster ##########

curlew:/root# portmaster -G samba44

===>>> Currently installed version: samba44-4.4.14
===>>> Port directory: /usr/ports/net/samba44

===>>> Launching 'make checksum' for net/samba44 in background
===>>> Gathering dependency list for net/samba44 from ports
===>>> Launching child to install devel/p5-Parse-Yapp

===>>> samba44-4.4.14 >> devel/p5-Parse-Yapp (1/1)

===>>> Port directory: /usr/ports/devel/p5-Parse-Yapp

===>>> Launching 'make checksum' for devel/p5-Parse-Yapp in background
===>>> Gathering dependency list for devel/p5-Parse-Yapp from ports
===>>> Initial dependency check complete for devel/p5-Parse-Yapp

===>>> Continuing initial dependency check for net/samba44
===>>> Initial dependency check complete for net/samba44


===>>> samba44-4.4.14 >> (1)

===>>> The following actions will be taken if you choose to proceed:
        Upgrade samba44-4.4.14 to samba44-4.4.14_1
        Install devel/p5-Parse-Yapp

===>>> Proceed? y/n [y] n


===>>> If you would like to upgrade or install some, but not
       all of the above try adding '-i' to the command line.
curlew:/root# 


########## Example with pkg ##########

curlew:/root# pkg upgrade samba44
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
The following 2 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        compat6x-amd64: 6.4.604000.200810_3

Installed packages to be UPGRADED:
        samba44: 4.4.14 -> 4.4.15

Number of packages to be installed: 1
Number of packages to be upgraded: 1

The process will require 17 MiB more space.
21 MiB to be downloaded.

Proceed with this action? [y/N]: y
[1/2] Fetching samba44-4.4.15.txz: 100%   21 MiB   2.0MB/s    00:11    
Checking integrity... done (0 conflicting)
[1/2] Upgrading samba44 from 4.4.14 to 4.4.15...
Extracting samba44-4.4.15: 100%
[1/2] Installing compat6x-amd64-6.4.604000.200810_3...
Extracting compat6x-amd64-6.4.604000.200810_3: 100%
Message from samba44-4.4.15:
===============================================================================

How to start: http://wiki.samba.org/index.php/Samba4/HOWTO

* Your configuration is: /usr/local/etc/smb4.conf

* All the relevant databases are under: /var/db/samba4

* All the logs are under: /var/log/samba4

* Provisioning script is: /usr/local/bin/samba-tool

For additional documentation check: http://wiki.samba.org/index.php/Samba4

Bug reports should go to the: https://bugzilla.samba.org/

===============================================================================
Message from compat6x-amd64-6.4.604000.200810_3:
*******************************************************************************
*                                                                             *
* Do not forget to add COMPAT_FREEBSD6 into                                   *
* your kernel configuration (enabled by default).                             *
*                                                                             *
* To configure and recompile your kernel see:                                 *
* http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/kernelconfig.html *
*                                                                             *
*******************************************************************************

===>   NOTICE:

The compat6x-amd64 port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port

curlew:/root# pkg info -d samba44
samba44-4.4.15:
        libsunacl-1.0
        gnutls-3.5.13
        openldap-client-2.4.45
        python27-2.7.13_6
        python2-2_3
        py27-dnspython-1.15.0
        tevent-0.9.31
        talloc-2.1.9
        readline-7.0.3
        py27-iso8601-0.1.11
        popt-1.16_2
        libinotify-20160505
        gamin-0.1.10_9
        tdb-1.3.12,1
        ldb-1.1.29_1
        libarchive-3.3.1,1

curlew:/root# pkg info -r compat6x-amd64
compat6x-amd64-6.4.604000.200810_3:

curlew:/root# pkg delete compat6x-amd64
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 1 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
        compat6x-amd64-6.4.604000.200810_3

Number of packages to be removed: 1

The operation will free 17 MiB.

Proceed with deinstalling packages? [y/N]: y
[1/1] Deinstalling compat6x-amd64-6.4.604000.200810_3...
[1/1] Deleting files for compat6x-amd64-6.4.604000.200810_3: 100%
curlew:/root#
Comment 1 Mike Clarke 2017-07-17 17:00:04 UTC
Looks like samba44 isn't relevant to this problem. I've now tried upgrading several different packages at random and pkg always tries to install compat6x-amd64
Comment 2 Michael Konieczny 2017-07-20 10:35:31 UTC
I have exactly the same problem: https://forums.freebsd.org/threads/61666/

But it doesn't affect all packages: for example, beadm upgraded via pkg upgrade without pulling compat6x in.
Comment 3 Jean-Sébastien Pédron freebsd_committer 2018-01-18 09:26:32 UTC
I had the same problem. Following the suggestion from:

https://lists.freebsd.org/pipermail/freebsd-pkg/2017-August/002237.html

... did fix the problem for me.

Here is what I did:

1. pkg check -ad

This told me `gutenprint-base` was missing libreadline.so.6

2. This package doesn't exist anymore in the ports tree. There is `gutenprint` and `gimp-gutenprint`. As I don't currently need it, I simply removed `gutenprint-base`.

Now, installing/upgrading packages doesn't pull compat6x-amd64 anymore.
Comment 4 Walter Schwarzenfeld freebsd_triage 2019-08-15 04:23:13 UTC
See comment3. I close here - not a bug.