Bug 220820 - net/xrdp-devel: Update to 0.9.3
Summary: net/xrdp-devel: Update to 0.9.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Richard Gallamore
URL: https://github.com/neutrinolabs/xrdp/...
Keywords:
Depends on:
Blocks: 220819
  Show dependency treegraph
 
Reported: 2017-07-18 07:56 UTC by Koichiro Iwao
Modified: 2017-08-17 21:40 UTC (History)
2 users (show)

See Also:
meta: maintainer-feedback+
koobs: merge-quarterly?


Attachments
patch (6.61 KB, patch)
2017-07-18 07:56 UTC, Koichiro Iwao
meta: maintainer-approval+
Details | Diff
patch (7.53 KB, patch)
2017-08-02 02:33 UTC, Koichiro Iwao
meta: maintainer-approval+
Details | Diff
poudriere log (245.04 KB, text/x-log)
2017-08-03 12:51 UTC, Koichiro Iwao
no flags Details
file list (66.48 KB, text/plain)
2017-08-03 13:01 UTC, Koichiro Iwao
no flags Details
patch (7.55 KB, patch)
2017-08-03 13:31 UTC, Koichiro Iwao
meta: maintainer-approval+
Details | Diff
pougriere log (240.51 KB, text/x-log)
2017-08-03 13:32 UTC, Koichiro Iwao
no flags Details
shar (12.58 KB, text/plain)
2017-08-10 07:23 UTC, Koichiro Iwao
meta: maintainer-approval+
Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Koichiro Iwao freebsd_committer 2017-07-19 02:53:08 UTC
I'd appreciate if this merged into quarterly as this release includes critical bug fix to some users (ex. upstream issue #737).
Comment 2 Richard Gallamore freebsd_committer 2017-07-26 03:05:32 UTC
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: %%ETCDIR%%/reconnectwm.sh
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1

Can you please check pkg-plist?

WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to
make SVN happy.
WARN: Makefile: new ports should not set PORTEPOCH.
WARN: /usr/local/poudriere/ports/test/net/xrdp-devel/files/patch-configure.ac: patch was not generated using ``make makepatch''.  It is recommended to use ``make makepatch'' when you need to [re-]generate a patch to ensure proper patch format.
WARN: /usr/local/poudriere/ports/test/net/xrdp-devel/files/patch-sesman_sesman.ini: patch was not generated using ``make makepatch''.  It is recommended to use ``make makepatch'' when you need to [re-]generate a patch to ensure proper patch format.
0 fatal errors and 4 warnings found.

Also portlint complains about patches not being generated by make makepatch. Can you please regenerate them to appease portlint? thanks.
Comment 3 Koichiro Iwao freebsd_committer 2017-08-02 02:33:49 UTC
Created attachment 184936 [details]
patch

The new patch passes poudriere build for me. Also, `make stage check-orphans stage-qa` shows no error.

(snip)
Installed packages to be REMOVED:                           
        xrdp-devel-0.9.3,1    

Number of packages to be removed: 1                         

The operation will free 3 MiB.                              
[110amd64-testing] [1/1] Deinstalling xrdp-devel-0.9.3,1... 
[110amd64-testing] [1/1] Deleting files for xrdp-devel-0.9.3,1: .......... done                                         build of net/xrdp-devel ended at Wed Aug  2 11:15:46 JST 2017                                                           build time: 00:02:26          
[00:02:46] ====>> Cleaning up 
[00:02:46] ====>> Unmounting file systems                   
sudo poudriere testport -j 110amd64 -p testing -o net/xrdp-devel  135.33s user 40.15s system 105% cpu 2:46.96 total


I regenerated patch-configure.ac but didn't regenerated patch-sesman_sesman.ini because `make makepatch` doesn't generate correct patch.
Comment 4 Richard Gallamore freebsd_committer 2017-08-02 23:13:23 UTC
(In reply to Koichiro IWAO from comment #3)
Instead of using
LDFLAGS+=       -L${LOCALBASE}/lib and
CFLAGS+=        -I${LOCALBASE}/include

can the USES localbase be used instead?

Also, not positive, but the LDFLAGS/CFLAGS bit for ssl is also probably not needed with the  USES= ssl, not positive on this will check.

The bsd.port.options.mk bit with fuse can be changed to using option helpers.

FUSE_USES= fuse

Added the changes and going to do a full test run on all ssl branches.
Comment 5 Richard Gallamore freebsd_committer 2017-08-03 00:02:45 UTC
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: %%ETCDIR%%/reconnectwm.sh
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1
Comment 6 Richard Gallamore freebsd_committer 2017-08-03 06:05:47 UTC
Just verified, CFLAGS+= is not required, LDFLAGS+= only requires -lssl, the rest are redundant with the USES entries mentioned previously.

 Please fix the new file entry and the other items mentioned and everything will be green. Thanks for your contributions to the project! =]
Comment 7 Koichiro Iwao freebsd_committer 2017-08-03 12:41:47 UTC
(In reply to Richard Gallamore from comment #5)

How did you get plist issue? I checked it by poudriere and make check-orphans but no problem.
Comment 8 Koichiro Iwao freebsd_committer 2017-08-03 12:51:59 UTC
Created attachment 184986 [details]
poudriere log
Comment 9 Koichiro Iwao freebsd_committer 2017-08-03 12:52:41 UTC
pkg-plist includes reconnectwm.sh. The plist issue should not occur. See my poudriere log.

% <pkg-plist grep 'wm\.sh' 
@postunexec if cmp -s %D/etc/xrdp/startwm.sh.sample %D/etc/xrdp/startwm.sh; then rm -f %D/etc/xrdp/startwm.sh; fi
@postunexec if cmp -s %D/etc/xrdp/reconnectwm.sh.sample %D/etc/xrdp/reconnectwm.sh; then rm -f %D/etc/xrdp/reconnectwm.sh; fi
@sample %%ETCDIR%%/startwm.sh.sample
@sample %%ETCDIR%%/reconnectwm.sh.sample
Comment 10 Koichiro Iwao freebsd_committer 2017-08-03 13:01:57 UTC
Created attachment 184988 [details]
file list

And `make check-orphans` again, NO PROBLEM. 
Furthermore, the port SHOULD NOT install reconnectwm.sh but installs reconnectwm.sh.sample. Why you have reconnectwm.sh? See attached file list. 

% sudo make check-orphans               
====> Checking for pkg-plist issues (check-plist)           
===> Parsing plist            
===> Checking for items in STAGEDIR missing from pkg-plist  
===> Checking for items in pkg-plist which are not in STAGEDIR                                                          
===> No pkg-plist issues found (check-plist)
Comment 11 Koichiro Iwao freebsd_committer 2017-08-03 13:31:11 UTC
Created attachment 184991 [details]
patch

Updated patch.
Comment 12 Koichiro Iwao freebsd_committer 2017-08-03 13:32:33 UTC
Created attachment 184992 [details]
pougriere log

Again, updated patch has no plist issue with poudriere.
Comment 13 Richard Gallamore freebsd_committer 2017-08-04 00:52:49 UTC
post-stage:
        @${RM} ${STAGEDIR}${PREFIX}/etc/xrdp/rsakeys.ini
        @${RM} ${STAGEDIR}${PREFIX}/etc/xrdp/cert.pem
        @${RM} ${STAGEDIR}${PREFIX}/etc/xrdp/key.pem
.for f in sesman.ini startwm.sh xrdp.ini xrdp_keyboard.ini
        @${MV} ${STAGEDIR}${PREFIX}/etc/xrdp/$f
${STAGEDIR}${PREFIX}/etc/xrdp/$f.sample

It looks like the problem is that the file isn't in the post-stage target or pkg-plist. Just to verify my repo wasn't corrupt, I also tested on a different repo using the git mirror with the same error.

I really suggest using a version control for generating patches. It makes life much easier.

Also, because the fuse bit was dropped right before the targets, .include <bsd.port.options.mk> is no longer used. Please remove this.
Comment 14 Koichiro Iwao freebsd_committer 2017-08-10 07:23:47 UTC
Created attachment 185217 [details]
shar

Something's going wrong. Of course I've already written reconnectwm.sm.sample to pkg-plist and Makefile but now appear in the diff. I attach whole port directory instead of diff.
Comment 15 Koichiro Iwao freebsd_committer 2017-08-10 07:34:03 UTC
I already use generating patches by version control. 

* edit files in the source git repo
* git diff --no-prefix > ${XRDP_DEVEL_PORT_DIR}/files/patch-foobar

Additionally, I modify files in post-patch target because some paths should be 
replaced with variables such as ${PREFIX}. I believe patches in files directory
cannot do this. Is this correct, right?
Comment 16 Richard Gallamore freebsd_committer 2017-08-10 16:58:16 UTC
(In reply to Koichiro IWAO from comment #15)
I mean version control for generating the patch for the entire port. I was able to get a usable diff from attached shar so that will work. It is not a standard way way for updating a port though.

Everything looks in order, I reran qa and found that my suggestion earlier was incorrect about removing CFLAGS/LDFLAGS so I reverted that part of the suggestion.
Comment 17 commit-hook freebsd_committer 2017-08-10 18:32:36 UTC
A commit references this bug:

Author: ultima
Date: Thu Aug 10 18:31:35 UTC 2017
New revision: 447713
URL: https://svnweb.freebsd.org/changeset/ports/447713

Log:
  * Updated to 0.9.3
  * Cleanup Makefile
  * Regenerated patch for portlint

  Changes: https://github.com/neutrinolabs/xrdp/releases/tag/v0.9.3Changes: https://github.com/neutrinolabs/xrdp/releases/tag/v0.9.3

  PR:		220820
  Submitted by:	Koichiro IWAO (maintainer)
  Reviewed by:	lifanov (mentor)
  Approved by:	lifanov (mentor)
  MFH:		2017Q3
  Differential Revision:	https://reviews.freebsd.org/D11956

Changes:
  head/net/xrdp-devel/Makefile
  head/net/xrdp-devel/distinfo
  head/net/xrdp-devel/files/patch-configure.ac
  head/net/xrdp-devel/files/patch-sesman_sesman.ini
  head/net/xrdp-devel/files/patch-xrdp_xrdp.ini
  head/net/xrdp-devel/pkg-plist
Comment 18 Richard Gallamore freebsd_committer 2017-08-10 18:37:55 UTC
Waiting on MFH approval.
Comment 19 commit-hook freebsd_committer 2017-08-17 21:15:45 UTC
A commit references this bug:

Author: ultima
Date: Thu Aug 17 21:14:40 UTC 2017
New revision: 448192
URL: https://svnweb.freebsd.org/changeset/ports/448192

Log:
  MFH: r447713

  * Updated to 0.9.3
  * Cleanup Makefile
  * Regenerated patch for portlint

  Changes: https://github.com/neutrinolabs/xrdp/releases/tag/v0.9.3Changes: https://github.com/neutrinolabs/xrdp/releases/tag/v0.9.3

  PR:		220820
  Submitted by:	Koichiro IWAO (maintainer)
  Reviewed by:	lifanov (mentor)
  Approved by:	lifanov (mentor)
  Differential Revision:	https://reviews.freebsd.org/D11956

  Approved by:	ports-secteam (feld)

Changes:
_U  branches/2017Q3/
  branches/2017Q3/net/xrdp-devel/Makefile
  branches/2017Q3/net/xrdp-devel/distinfo
  branches/2017Q3/net/xrdp-devel/files/patch-configure.ac
  branches/2017Q3/net/xrdp-devel/files/patch-sesman_sesman.ini
  branches/2017Q3/net/xrdp-devel/files/patch-xrdp_xrdp.ini
  branches/2017Q3/net/xrdp-devel/pkg-plist