Bug 220907 - net/kea: remove unused dependency on python 3.3+
Summary: net/kea: remove unused dependency on python 3.3+
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Koichiro Iwao
URL:
Keywords: easy
Depends on:
Blocks:
 
Reported: 2017-07-21 16:59 UTC by Andrew Fyfe
Modified: 2018-10-23 07:44 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (hrs)
koobs: merge-quarterly?


Attachments
net/kea: remove python dependency (412 bytes, patch)
2017-07-21 16:59 UTC, Andrew Fyfe
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Fyfe 2017-07-21 16:59:11 UTC
Created attachment 184577 [details]
net/kea: remove python dependency

net/kea does not depend on python 3.3+ as kea-shell is not built. This is confirmed by the report at the end of ./configure (see below). 


       Kea source configure results:
    -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

Package:
  Name:            kea
  Version:         1.2.0
  Extended version:1.2.0 (tarball)
  OS Family:       BSD
  Using GNU sed:   no
  Premium package: no

C++ Compiler:
  CXX:             c++ --std=c++11
  CXX_VERSION:     FreeBSD clang version 3.8.0 (tags/RELEASE_380/final 262564) (based on LLVM 3.8.0)
  CXX_STANDARD:    201103
  DEFS:            -DHAVE_CONFIG_H
  CPPFLAGS:         -DOS_BSD  -I$(top_srcdir)/ext/coroutine -DBOOST_ASIO_HEADER_ONLY -DBOOST_ASIO_DISABLE_THREADS=1 -DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED
  CXXFLAGS:        -O2 -pipe -fstack-protector -fno-strict-aliasing 
  LDFLAGS:          -Wl,-rpath,/usr/local/lib -fstack-protector -lpthread
  KEA_CXXFLAGS:     -Qunused-arguments -Wall -Wextra -Wnon-virtual-dtor -Wwrite-strings -Woverloaded-virtual -Wno-sign-compare -pthread -Wno-missing-field-initializers -Wno-unused-variable -Wno-unused-parameter -fPIC

Python:
  PYTHON_VERSION:  not needed (because kea-shell is disabled)

Boost:
  BOOST_VERSION:   1.64
  BOOST_INCLUDES:  -I/usr/local/include
  BOOST_LIBS:      

OpenSSL:
  CRYPTO_VERSION:  LibreSSL 2.5.5
  CRYPTO_CFLAGS:   
  CRYPTO_INCLUDES: -I/usr/local/include
  CRYPTO_LDFLAGS:  
  CRYPTO_LIBS:     -L/usr/local/lib -lcrypto

Botan: no

Log4cplus:
  LOG4CPLUS_VERSION: 1.1.2
  LOG4CPLUS_INCLUDES: -I/usr/local/include
  LOG4CPLUS_LIBS:  -L/usr/local/lib -llog4cplus

Flex/bison:
  FLEX:  flex
  BISON: byacc

MySQL:
  no

PostgreSQL:
  no

Cassandra CQL:
  no

Developer:
  Enable Debugging: no
  Google Tests: no
  Valgrind: not found
  C++ Code Coverage: no
  Logger checks: no
  Generate Documentation: no
  Parser Generation: no
  Kea-shell: no
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-01-10 04:11:31 UTC
Maintainer timeout?
Comment 2 Koichiro Iwao freebsd_committer 2018-10-23 06:59:23 UTC
Take due to maintainer timeout.
Comment 3 commit-hook freebsd_committer 2018-10-23 07:43:09 UTC
A commit references this bug:

Author: meta
Date: Tue Oct 23 07:42:12 UTC 2018
New revision: 482813
URL: https://svnweb.freebsd.org/changeset/ports/482813

Log:
  net/kea: remove unused dependency on python 3.3+

  Also,
  * Bump PORTREVISION due to dependency change

  PR:		220907
  Submitted by:	Andrew Fyfe
  Approved by:	maintainer timeout (15 months), mentors (implicit)

Changes:
  head/net/kea/Makefile
Comment 4 Koichiro Iwao freebsd_committer 2018-10-23 07:44:18 UTC
Committed with trivial changes (PORTREVISION), thanks!